Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I enable wallpaper compiz plugin all icons disappear from desktop. How can I fix that?

share|improve this question
    
Which icons are you talking about? The ones of the files on the desktop or those of Computer, Trash, etc? –  duxk.gh May 4 '13 at 16:05
    
The ones from desktop, not from dash. –  Mislav Blažević May 4 '13 at 16:07
    
Yes I understand but I'm wondering if it's normal files (such as images, documents, etc) or things like the Trash, Home Folder, etc. Which are not showing up? Can you see anything on the desktop? –  duxk.gh May 4 '13 at 16:09
    
I can't see anything on desktop. I had few custom .desktop icons. –  Mislav Blažević May 4 '13 at 16:15
1  
sigh For example, I have World of Warcraft.desktop Which is a wrapper for optirun/vgl/wine. Others are similar. No . at begining of name. –  Mislav Blažević May 4 '13 at 16:35
show 1 more comment

3 Answers 3

up vote 2 down vote accepted
+100

Unfortunately, this is not possible. To get desktop icons back you will have to disable the Compiz Wallpaper plugin and allow Nautilus/Files to draw your desktop.

The Compiz Wallpaper plugin can draw your background, which can allow you do do some cool stuff (like have a different background image for each workspace). But this conflicts with Nautilus' ability to draw the desktop, and only Nautilus can display desktop icons.

For more information, see the answers to this question. Apparently people have tried to make Nautilus draw a transparent desktop so you can see the images from the Compiz Wallpaper plugin behind the Nautilus icons, but those efforts have not yet been successful.

share|improve this answer
add comment

Ubuntu 13.04

I have tested it in Ubuntu 13.04 and its working.

sudo apt-get install unity-tweak-tool 

enter image description here

enter image description here

I have also restarted the system and its working.

share|improve this answer
    
I need my custom icons and not home/network/rubbish bin/devices... –  Mislav Blažević May 9 '13 at 18:10
    
You need home folder with custom icon ? –  Qasim May 9 '13 at 18:17
    
Nooo. I have my own .desktop icons I created. See comments on question. –  Mislav Blažević May 9 '13 at 20:15
    
ok enable desktop icon, have one on desk like home icon and place your icon as well ..check if its working –  Qasim May 9 '13 at 23:45
    
Crashes on launch. paste.ubuntu.com/5654611 –  Mislav Blažević May 11 '13 at 14:08
add comment

You can try to use Ubuntu Tweak and go to Tweaks → Desktop icons to turn them on and select which you want to show.

You can download Ubuntu Tweak here, or add a PPA and install it with the following commands:

 sudo add-apt-repository ppa:tualatrix/ppa
 sudo apt-get update
 sudo apt-get install ubuntu-tweak

enter image description here

share|improve this answer
    
It doesn't help. –  Mislav Blažević May 4 '13 at 16:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.