Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried creating a USB boot drive but it always fails with a message from Syslinux and a boot: prompt.

unknown keyword in configuration file FILE0
boot:

I've checked the md5sum of the iso - the iso is fine. This occurs with both the 12.04.2 and 13.04 images. Both the images are the 64 bit variants. I have not tried the 32 bit variants.

None of the computers have Windows 8 installed (Vista / Windows 7).

I've tried multiple tools to write the iso to the usb disk (unetbootin, lili, startup disk creater - but none of them work.

Some posts mentioned to edit the syslinux.cfg file - I couldn't do that as it was a binary file (started with FILE0 and then some binary )

I've also tried multiple USB flash drives and none have worked. The drives work fine otherwise and one of them is brand new. Hence I don't think it is a problem with the USB pen drives either.

I think it's something to do with UEFI - but not sure what. I intend to try the 32 bit versions to check if that is the case as I guess the 32 bit ones are not UEFI?

I'm not sure what's wrong.

share|improve this question

1 Answer 1

syslinux.cfg must be a text file, not binary, here is the SYSLINUX documentation. Can you just borrow a working file, or create a new one with an entry

label live 
menu label Start Linux 
kernel /casper/vmlinuz 
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz --

(remove the persistent file=/cdrom/preseed/ubuntu.seed if you don't have one)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.