Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know that there is lots of people with the exact same problem, but I can't get an answer from another place (I've really been trying for hours), so here is my problem.

I got Ubuntu 13.04 on my CD and I installed it beside Windows. Something went wrong and it said

"Executing 'grub-install /dev/sda' failed. This is a fatal error"

I could choose where to install the bootloader and I selected /sda . But after rebooting, I went to Windows, which I didn't wanted to. I tried the boot-repair (recommended) and it said:

Boot successfully repaired.

You can now reboot your computer. Please do not forget to make your BIOS boot on sdb (500GB) disk!

I rebooted and I got ubuntu, just like I wanted. But then after an hour of using, I pressed at 'Shut down'. Like 2 hours after, I came Again but saw the Windows logo another time. I tried to use the boot-repair and it said the exact same thing, but when I rebooted I just went to Windows Again.

So That's my problem. I have the link for the first boot-repair 'installation' right here: http://paste.ubuntu.com/5631563/.

Does anybody have an idea of what to do? Can I activate something that will make the computer asking me for which OS I wanna use when I start up (It did after the first boot-repair)? Or can't I just make ubuntu my default?

UPDATE: In BIOS Settings, I can choose between these:

  • International CD/DVD ROM DRIVE
  • USB Diskette on Key/USB Hard Disk
  • USB CD/DVD ROM Drive
  • Notebook Hard Drive (Really think this is Windows)
  • ! USB Floppy
  • ! Network Adaptor
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You have two 500 GB hard drives. It seems like there are multiple windows systems installed on the first drive (sda1, sda2, sda3), and a Ubuntu system on the second drive (sdb6). To reach the GRUB menu, you simply need to set your BIOS to boot from the second HDD, as boot-repair told you, because GRUB is installed in the MBR of sdb.

share|improve this answer
    
I updated the first post. Which one do you think I should use? I listed them like the first post, so it starts with the International CD (...) and end with the "! Network Adaptor". But I can't reach GRUB menu. –  user1994248 May 4 '13 at 14:29
    
Try booting the USB Hard Disk, is your second drive an external USB drive? Seems like there is also a 4GB flash drive, remove that for now. Do you have the Ubuntu installer on a CD? –  grimpitch May 4 '13 at 15:00
    
Yes, I have Ubuntu 13.04 installer on a CD. I'm not really sure what the external is, and what anything is. Only that the Notebook Hard drive is Windows. –  user1994248 May 4 '13 at 15:02
    
Try the second option in the BIOS "USB Diskette on Key/USB Hard Disk". External means, that the device is plugged into the notebook by a USB or other connector. Is anything connected to your notebook that way? –  grimpitch May 4 '13 at 15:17
    
Well, only the CD that contains the ubuntu installer. –  user1994248 May 4 '13 at 15:18
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.