Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I chose my ~/Music directory as my library location in Rhythmbox, but rhythmbox is still displaying songs that are located in other directories. (All the music in my ~/Music folder is in ALAC, but I keep the original flac files in a separate directory for the day my ipod dies and I can completely go with flac) How can I prevent this? I didn't have this problem on 12.04, but after a clean install of 13.04 I have.

Thanks!

EDIT: I noticed "Music" (in Rhythmbox) kan be expanded to "Music" and "Purchased". The former contains only the files from my ~/Music folder as it should. But the "global" Music still show all the files from other folders too.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Two key areas you should check to resolve this.

check 1

pic

In the preferences window you may have a location/multiple locations where rhythmbox is monitoring both the folder(s) set and also sub-folders

pic

You can change these locations either via the Browser button - or using dconf-editor

dconf-tools

Install dconf-tools

check 2

If you have in the past inadventently imported from another folder location, rhythmbox will remember this.

Thus, you'll need to reset your rhythmbox database - remove the rhythmdb.xml file found in ~/.local/share/rhythmbox

Then reimport all of your music again.


Linked question:

share|improve this answer
    
Resetting my rhythmbox database did the trick. Thanks! –  user138784 May 4 '13 at 19:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.