Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying run website on ubuntu server but it does not work. This is my configuration:

/etc/apache2/sites-available/vtiger

<VirtualHost *:33333>
ServerName my.domain.com
DocumentRoot /var/www/vtigercrm/
ErrorLog /var/log/apache2/vtiger.my.domain.com.error_log
CustomLog /var/log/apache2/vtiger.my.domain.com.access_log combined
<Directory /var/www/vtigercrm>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>
</VirtualHost>

/etc/apache2/sites-enabled/vtiger

<VirtualHost *:33333>
ServerName my.domain.com
DocumentRoot /var/www/vtigercrm/
ErrorLog /var/log/apache2/vtiger.my.domaincom.error_log
CustomLog /var/log/apache2/vtiger.my.domain.com.access_log combined
<Directory /var/www/vtigercrm>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>
</VirtualHost>

/etc/apache2/ports.conf

NameVirtualHost *:33333
Listen 33333

<IfModule mod_ssl.c>
    # If you add NameVirtualHost *:443 here, you will also have to change
    # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
    # to <VirtualHost *:443>
    # Server Name Indication for SSL named virtual hosts is currently not
    # supported by MSIE on Windows XP.
    Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    Listen 443
</IfModule>

What is wrong? How to fix it? There are no errors in the logs

I'm trying also run: my.domain.com:33333 but this return:

The connection has timed out

share|improve this question
    
Are you getting any error when accesses from the browser? –  thefourtheye May 4 '13 at 9:14
    
@thefourtheye If I run: my.domain.com this load page from my server for example: 144.76.57.14. My domain is pointing to this IP. Not load page from /var/www/vtigercrm/ –  user2307683 May 4 '13 at 9:20
    
Did you restart apache after adding new virtualhost configuration and enabling it? –  saji89 May 4 '13 at 9:25
    
Does localhost:33333 work? –  saji89 May 4 '13 at 9:25
    
Yes. I restarted Apache and my.domain.com:33333 return The connection has timed out –  user2307683 May 4 '13 at 9:27
show 2 more comments

1 Answer 1

-{instal Xampp }

1)create /etc/apache2/sites-available/site.qw


<VirtualHost *:80>

ServerName site.qw

# ServerAlias example.com

ServerAdmin webmaster@example.com

DocumentRoot /home/user/sites/site.qw/www

<Directory /home/user/sites/site.qw/www>

Options -Indexes FollowSymLinks MultiViews

AllowOverride All

Order allow,deny

allow from all

</Directory>

ErrorLog /home//user/sites/site.qw/logs/error.log

LogLevel warn

ServerSignature On

</VirtualHost>


<<<

2)create:\

     /home/user/sites/site.qw/www/index.html   ----your web site

     /home/user/sites/site.qw/logs/error.log   ----logs

3)activate site, write in terminal: a2ensite site.qw

4)redirection edit file: /etc/hosts add new line and write: 127.0.0.1 site.qw

5)restars apache, write in terminal: service apache2 restart

6)open in your browser site.qw/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.