Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu (almost all latest versions), when my Acer Aspire V5-471 is want to shutdown from Ubuntu, it acts as restart/reboot. Refer to edit 2 for releases tried and edit 1 for tried derivatives.

edit 1: It's happens on 2 versions (till now), Ubuntu and Ubuntu Studio/Xubuntu (both Ubuntu-studio and XFCE session).

edit 2: Same as edit 1 (only for live-user, others only uses Ubuntu), happened on Normal installation (12.04 to 13.04), Wubi installation (12.04 only), and Live User Session (12.04 to 13.04).

Rebooted after short shutdown time even as root or sudo-ing from this command :

shutdown -h now

Why? Can I fix this?

share|improve this question
    
Can you tell us what is actually happening? So what do you do to start the "shutdown", what do you see on your screen, etc. YOu can also check your syslog for messages. –  Nanne May 4 '13 at 6:42
    
Not enough information is provided. There is a translucent popup right? Which did you click? –  owl May 4 '13 at 6:47
    
@owl I just click shutdown. –  Aryo Adhi May 4 '13 at 6:51
    
@AryoAdhiWibisonoLegopermono What about you do 'sudo shutdown -h' on Terminal? –  owl May 4 '13 at 7:23
    
I'll try it... i'll recomment if that successfull –  Aryo Adhi May 4 '13 at 7:29
show 2 more comments

2 Answers 2

Upgrading the mainline 3.9 kernel appears to solve it.

See here for installation direction.

share|improve this answer
add comment

This is true in Debian, I assume the same is true in Ubuntu.

shutdown takes arguments in order to achieve specific events. I guess in Ubuntu, they made the default for shutdown an alias to shutdown -r now (-r for restart, now for, well, now). If you want to halt the system, or shutdown, do shutdown -h now (-h for halt) and that should do what you want.

share|improve this answer
    
tried and keeps reboot... running as root –  Aryo Adhi May 14 '13 at 5:19
    
shutdown -h now does? Perhaps the above user is correct then, the -h switch should never cause a reboot, that should be a halt –  Seth Curry May 14 '13 at 13:19
    
I don't know what's happening on my notebook, and it's always REBOOT even running it as root or sudo-ing first... Going to record and upload to YouTube. –  Aryo Adhi May 14 '13 at 13:46
    
According to this from the Mint forums which should be running the same base, this is due to a Wake on LAN error, try disabling your wireless in the BIOS and then rebooting and try it again. According to them shutdown works fine, but WoL is triggering a power on as soon as you shut down, making it seem like a reboot. –  Seth Curry May 14 '13 at 15:25
    
Already disabled, but won't shutdown. I think it's hardware-specific problem. –  Aryo Adhi May 17 '13 at 14:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.