Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 13.04 and notice that my mouse is behaving weirdly. If I try to drag a selected text, folders or files, sometimes the selection will loose. If I make one click, sometimes, it will add two clicks. It happens in both my Laptop and the Desktop machines. Two different mouse. How can we fix this?

share|improve this question

closed as off topic by Luis Alvarado May 17 '13 at 15:20

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
did you tweak something, like double-click speed or something? How is the test result in your `mouse & touchpad test result? –  gongzhitaao May 6 '13 at 5:13
1  
I tried to reduce the double click speed. But it didn't help. Even reformatted the system –  EApubs May 6 '13 at 5:48
1  
I can confirm this problem. I thought it was my mouse but I tried 3 more and same problem. In my case and I suspect EApubs case, I did not change anything at all related to mouse settings. Not even sensibility. The problem can be reproduce faster if you open Nautilus and select several files or folders with the intention of copying them, then immediately after selecting them, right click for the context menu to appear. When the context menu appears, you will loose the selected objects. This only happens the first time. –  Luis Alvarado May 6 '13 at 23:22
    
I have the same problem in both 12.10 and to a lesser extent in 13.04 on my brand new laptop. I sense it might have to do with the sensitivity slider in the mouse/trackpad configurations. –  charlie May 10 '13 at 6:43
    
@EApubs: '...happens in both my Laptop and the Desktop machines.' Including the laptop's touchpad? –  Aryo Adhi May 10 '13 at 9:08

2 Answers 2

This has happened me all the time since I started to use computers as daily basis. What is happening, most likely, is that your mouse (both) are getting old, the push button inside is getting weaker because of extensive use, ending in multiple clicks.

All you can do is getting a new mouse, in fact I'm about to get one because the same reason.

EDIT:

As it is likely to be a hardware problem with the mouse itself. Found this instructable to repair this issue. Repair-mouse-with-double-click-problem

EDIT2:

You could also try to change the "Double-Click Timeout" to "Short" in "Mouse and Touchpad" Settings

share|improve this answer
    
The mouse I use in my PC is brand new. Bought in January. The other mouse is several years old. But the problem comes in both of them. In two different machines! But its not there in Windows. I didn't even faced it in Ubuntu 12.10. Only in 13.04! –  EApubs May 7 '13 at 2:55
    
"You could also try to change the "Double-Click Timeout" to "Short"" fast maybe? –  Aryo Adhi May 7 '13 at 6:13
    
@AryoAdhi Tried that but didn't work –  EApubs May 8 '13 at 4:23

A bug report was created since it affects several users: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1181272

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.