Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some time now I have had problems with eclipse giving 100% cpu when starting up. After making a new workspace and switching to it, I noticed Android dev tools no longer show up anywhere. In fact, File-New-project only shows "General" and "CVS" projects. I have ia32 libs, eclipse-jdt, but nothing shows up except in the Help-install new software, which says it's installed.

share|improve this question

2 Answers 2

I have had a lot of issues with the Eclipse that is in the Ubuntu repositories. I've found it's much better to just dowload it and run it directly. If you're doing Android, I highly recommend the Android SDK/ADT bundle. It doesn't get much easier than that. If you need Eclipse for other projects you can get it at their website.

share|improve this answer
up vote 0 down vote accepted

I ran Eclipse with sudo, updated and installed everything I needed, then ran sudo chown -R username:username ./workspacedirectory. (Same with a .metadata directory, when I had problems later). This seems to be the solution! Strange, since sometime before 13.04 updates I though for sure I had tried something like this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.