Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have freshly installed Ubuntu 12.04 LTS 64 bit on a dual-boot with Windows 7 64 bit, and the first thing I did was to install myunity by sudo:

sudo apt-get install myunity

I also ran several commands on the terminal to make ubuntu recognise my touchpad as a touchpad, not a mouse. It worked fine.

I know realise, when I run myunity, that an error pops up and says that I am in unity 2d.

I have read posts but never had a clear answer. I know it must have something to do with my Nvidia Gt540M Optimus with a Intel HD 3000. I have also heard of bumblebee, which can solve Nvidia/Optimus issues.

SO I basically want to know how to put unity in 3d mode, and enable some sort of support for my Nvidia cards.

I am only 14, and beginning on Ubuntu, after a disastrous trial on Mint 13, so I would enjoy some very clear instructions and answers :)

My specs:

  • Asus K53sv

  • CPU: Intel i5 2410m 2.3Ghz; Intel HD 3000 graphics

  • RAM: 4gb RAM

  • GPU: Nvidia Cuda GT540m @gb Optimus w/ Intel HD 3000

  • HDD: ATA Hitachi 640gb

I don't know what motherboard I have..

share|improve this question
    
Please run this at a terminal and add the output on your original post: lshw -c display –  Jorge Suárez de Lis May 4 '13 at 9:00
    
WARNING: you should run this program as super-user. *-display description: VGA compatible controller product: 2nd Generation Core Processor Family Integrated Graphics Controller vendor: Intel Corporation physical id: 2 bus info: pci@0000:00:02.0 version: 09 width: 64 bits clock: 33MHz capabilities: vga_controller bus_master cap_list rom configuration: driver=i915 latency=0 resources: irq:44 memory:dd400000-dd7fffff memory:b0000000-bfffffff ioport:e000(size=64) WARNING: output may be incomplete or inaccurate, you should run this program as super-user. –  ROBIN Corentin May 6 '13 at 10:37
add comment

5 Answers 5

I think unity 3d should be automatically enabled after installing the right drivers. There should be a program for this called restricted driver. Just search for drivers in the Dash.

share|improve this answer
    
Thank you for answering. I did not find this "restricted driver", but I am however downloading an official Nvidia driver for "linux 64 bit", for my gt540m. However, my pc uses Optimus tech, and I would like to know if there is some sort of support for this tech on Ubuntu (for battery and performance issues, mostly). Thank you for the quick response :) –  ROBIN Corentin May 4 '13 at 10:12
    
sorry it is called additional drivers. If you can't find it search the software center. I doubt it is a good idea to install the nVidia driver from their website if you are new to ubuntu. Bublebee should enable bumblebee-project.org optimus support. The nvidia driver version 319.12 supports optimus out of the box but I haven't tried it yet. h-online.com/open/news/item/… –  grissir May 4 '13 at 16:33
    
I tried to download the nvidia driver, but ended up with a .run file, which I have never encountered before, so I did nothing. Might be a good thing after all. I had already heard of bumblebee and followed their official instructions to install it by command line. However I cannot find it in the dash, so I suppose Bumblebee doesn't have a graphical interface, so I think it's the reason I can't find it in the dash. To sum it up, I think I have correctly installed Bumblebee, but cannot find it in the dash. Since it does not have a graphical interface, I do not know how to use it. Thank you again –  ROBIN Corentin May 5 '13 at 2:58
add comment

In response to Jorge Suarez de Lis' proposition, I ran this command line:

lshw -c display

Here are the results:

WARNING: you should run this program as super-user.

*-display

description: VGA compatible controller

product: 2nd Generation Core Processor Family Integrated Graphics Controller

vendor: Intel Corporation

physical id: 2

bus info: pci@0000:00:02.0

version: 09

width: 64 bits

clock: 33MHz

capabilities: vga_controller bus_master cap_list rom

configuration: driver=i915 latency=0

resources: irq:44 memory:dd400000-dd7fffff memory:b0000000-bfffffff ioport:e000(size=64)

WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Hope this can help.

By the way, I would like to thank everyone for quick answers, I must admit it changes from the grumpy Microsoft forum admins :)

share|improve this answer
add comment

Ok. I now seem to be in Unity3d (normal Unity). I did absolutely nothing. And I just noticed that I could open myunity without the error message saying I was in 2d mode.

So that's one problem ruled out! Thanks!

Now the question would be: how to use Bumblebee to have Optimus support? Bumblebee doesn't seem to have a graphical interface, so I'm sort of...lost.

Once again, my specs, if they can help:

Asus K53sv

CPU: Intel i5 2410m 2.3Ghz; Intel HD 3000 graphics

RAM: 4gb RAM

GPU: Nvidia Cuda GT540m @gb Optimus w/ Intel HD 3000

HDD: ATA Hitachi 640gb

P.S. I run Ubuntu 12.04 LTS 64-bit in dual-boot with Windows 7.

share|improve this answer
add comment

I had the same problem with about the same hardware (GT520M instead). You need to install a graphics driver for the card. Installing bumblebee will let you use the Intel HD graphics by default (to save battery time) and the option to run applications with the Nvidia graphics card (using optirun). First, add the bumblebee repository and update:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update

Then, you can either install the open-source driver (Nouveau):

sudo apt-get install bumblebee

Or, for the proprietary Nvidia driver:

sudo apt-get install bumblebee-nvidia

Then, reboot and unity 3d should be working. To launch applications using the nvidia card simply do:

optirun <program name>

You can see the Ubuntu bumblebee page you more info. Hope this helps!

share|improve this answer
    
It says "E: Package 'bumblebee' has no installation candidate", and "E: Package 'bumblebee-nvidia' has no installation candidate". I cannot install Bumblebee. –  ROBIN Corentin May 6 '13 at 12:14
    
Ok, no problem now, again, I did nothing and it just worked...I tried optirun and it seemed to work. Thank you! –  ROBIN Corentin May 6 '13 at 14:56
    
No problem, I'm glad you got it working! –  francismb May 7 '13 at 2:13
add comment

Alright. Bumblebee is installed and the optirun command seems to be working. Is there a way to check that:

Power consumption and performance goes up with optirun.

Power consumption and performance goes down after closing the application.

Anyhow, thank you again for some outstanding support! Ubuntu IS hard, but with such support, you just can't get your hands off :) Thanks!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.