Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to configure a setting with gsettings in the Terminal, to avoid having to install special non-default applications to configure the settings. However, when doing so, gsettings complains the setting has a relocatable schema and does nothing.

#: gsettings set org.compiz.unityshell dash-blur-experimental 1
Schema 'org.compiz.unityshell' is relocatable (path must be specified)

How can I set the value with the gsettings command?

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

You need to specify the path to the key where the setting is actually stored. As an example, for this key, you need to use the /org/compiz/profiles/unity/plugins/unityshell/ path when running the command, like so:

#: gesettings set org.compiz.unityshell:/org/compiz/profiles/unity/plugins/unityshell/ dash-blur-experimental 1

Note that the path must end with a / character, when passed in for relocatable schemas.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.