Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i'm using a dell laptop the wifi turns off automatically after some time and only if i restart the machine it work this happens very often

I have already tried the MTU method it is in automatic and this problem happens in both college(proxy) and home networks(no proxy)

And deleting the connections from the menu and turning off and on the wifi doesnt work is there any permanent solution for this

    *-network
   description: Wireless interface
   product: Centrino Wireless-N 2230
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:08:00.0
   logical name: wlan0
   version: c4
   serial: 68:5d:43:5e:b1:f9
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=3.8.0-19-generic firmware=18.168.6.1 ip=192.168.40.202 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   resources: irq:45 memory:c1500000-c1501fff
share|improve this question
    
Wow! I only just installed 13.04... you're way ahead! –  duxk.gh May 3 '13 at 14:04
    
oops sorry its 13.04 only –  Vishnu667 May 3 '13 at 14:07
    
Check this [link][1] If you're using acer_wmi driver this may help you [1]: askubuntu.com/questions/225613/… –  ThundLayr May 3 '13 at 15:11
    
this is my wifi driver: 08:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4) i checked that post and that is a different wifi device @ThundLayr –  Vishnu667 May 3 '13 at 15:20

3 Answers 3

I had a similar issue upon upgrade as well recently - might not be the exact same as yours (I have a HP laptop with a Realtek wireless), but I found that using an older kernel version fixed it for now... so during boot, hold down ESC and select a 3.5.x kernel and see if that helps...

share|improve this answer
    
and its a fresh install so i dont have the older kernel versions and i had the same problem with ubuntu 12.10 also –  Vishnu667 May 3 '13 at 14:08
    
While it may not solve your specific problem, you can use apt-get to install other kernel versions, for e.g., sudo apt-get install linux-image-3.5.0-27-generic –  Prashant Nayak May 3 '13 at 17:43
    
i did that too but still i have the same issue it got disconected after 20 minutes i had the same issue with ubuntu 12.10 but when i was using 12.04 everythin worked perfectly @Prashant Nayak –  Vishnu667 May 3 '13 at 18:41

Same thing happens to me on a Dell Inspiron 15r with the Centrino Wireless-N 2230, stops working (lshw -C network reports an "illegal device vendor" and "Illegal product" instead of the right values. Restart the system and sometimes the wireless adapter is not detected at all, so I remove the battery, unplug the power cord, insert battery and boot the system. Wifi is on again, but after some random time it goes off...

My kernel is 3.8.0-32-generic (Ubuntu 13.04 64Bit)

share|improve this answer
    
If you have a NEW question, please ask it by clicking the Ask Question button. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favorite and you will be notified of any new answers. –  LiveWireBT Oct 23 '13 at 19:34
up vote 0 down vote accepted

Upgrading to the latest Version Ubuntu 14.04 Fixed the issue 12.04 still has the same Problem with the Driver

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.