Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a VPS with Ubuntu Server 10.10 x64.

I tried to install Java using apt-get install openjdk-6-jre but that fails, see ca-certificates-java fails to install.

Now I would like to install PHP with sudo apt-get install nginx php5-fpm php-apc php5-pgsql php5-suhosin but that also fails, with the same error message as I had with Java. Why is that? How can I install other applications now after the installation of Java has failed?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You can't install other applications until you resolve the problem with ca-certificates-java. apt-get won't let you keep any packages in an unconfigured state.

If you are not able to resolve the problem (you should - just google the error message Java gives you), force removal of the package:

sudo mv /var/lib/dpkg/info/ca-certificates-java.postinst /var/lib/dpkg/info/ca-certificates-java.postinst.backup
sudo apt-get purge ca-certificates-java
share|improve this answer

it seems like a broken ca-certificates-java package. Because the apt error says:

1 not fully installed or removed.

First try to remove it with: dpkg -r ca-certificates-java

and reinstall it with apt: apt-get install ca-certificates-java

if other Dependencies are not resolvable, try apt-get -f install to resolve failed dependencies.

share|improve this answer
    
dpkg -r ca-certificates-java returns this error message: dpkg: dependency problems prevent removal of ca-certificates-java: openjdk-6-jre-headless depends on ca-certificates-java. dpkg: error processing ca-certificates-java (--remove): dependency problems - not removing –  Jonas Mar 4 '11 at 15:10
    
And your other suggested commands just returns the same error messages as I had before. –  Jonas Mar 4 '11 at 15:11
    
Try a force install of the ca-certificates-java package: dpkg -i --force-all /var/cache/apt/archives/ca-certificates-java and take a look to the install status: dpkg -s ca-certificates-java –  schneehase Mar 4 '11 at 15:19
    
The command dpkg -i --force-all ... gives this result: dpkg: error processing /var/cache/apt/archives/ca-certificates-java (--install): cannot access archive: No such file or directory Errors were encountered while processing: /var/cache/apt/archives/ca-certificates-java –  Jonas Mar 4 '11 at 19:18
    
The command dpkg -s ca-certificates-java gives this result: Package: ca-certificates-java Status: install ok half-configured Priority: optional Section: java Installed-Size: 252 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> Architecture: all Version: 20100406ubuntu1 Depends: ca-certificates (>= 20090814), openjdk-6-jre-headless (>= 6b16-1.6.1-2) | java6-runtime-headless Recommends: libnss3-1d Conffiles: /etc/default/cacerts 0ded97abeff69c2362939e2e881e214a /etc/ca-certificates/update.d/jks-keystore 84ae89a338475ccc602f9b0128a124f3 –  Jonas Mar 4 '11 at 19:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.