Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to install a package but its failing in 12.04 64 -bit.

root@sun-To-be-filled-by-O-E-M:/var/tmp# apt-get install pcscd
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 eid-viewer : Depends: default-jre but it is not going to be installed
 pcscd : Depends: libccid (>= 1.4.1~) but it is not going to be installed or
                  pcsc-ifd-handler
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

root@sun-To-be-filled-by-O-E-M:~/Downloads/ifdokccid_lnx_x64-3.7.0# apt-get install libccid
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 eid-mw : Depends: pcscd but it is not going to be installed
          Recommends: libacr38u but it is not going to be installed
 eid-viewer : Depends: default-jre but it is not going to be installed
              Depends: pcscd but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@sun-To-be-filled-by-O-E-M:~/Downloads/ifdokccid_lnx_x64-3.7.0# apt-get -f install pcscd
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 eid-viewer : Depends: default-jre but it is not going to be installed
 pcscd : Depends: libccid (>= 1.4.1~) but it is not going to be installed or
                  pcsc-ifd-handler
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@sun-To-be-filled-by-O-E-M:~/Downloads/ifdokccid_lnx_x64-3.7.0# apt-get -f install pcsc-tools
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 eid-mw : Depends: pcscd but it is not going to be installed
          Recommends: libccid but it is not going to be installed
          Recommends: libacr38u but it is not going to be installed
 eid-viewer : Depends: default-jre but it is not going to be installed
              Depends: pcscd but it is not going to be installed
 pcsc-tools : Depends: libpcsc-perl but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
share|improve this question
add comment

1 Answer 1

$ dpkg -r eid-mw*
$ dpkg -r eid-viewer*
$ apt-get install default-jre default-jre-headless pcscd openct pcsc-tools
$ dpkg -i eid-mw.deb
$ dpkg -i eid-viewer.deb

INSTALLED - but pcscd is not running?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.