Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have posted a previous question about getting OpenVPN connected as a client (OpenVPN fails from Network Manager, seems to connect from terminal, but no traffic to or from target network) but no responses have been offered on that thread so far.

I have been using OpenVPN (server mode) on a Windows server in the office for some years now, which works fine with the Windows client PCs, but I cannot get a connection to work from Ubuntu.

I won't copy the log details here again (please see the link above), but would really appreciate advice on how I should proceed. I'm fairly new to Linux as a regular user, so explicitly noted steps would be appreciated.

All the instructions I have read seem to indicate it is simple to configure from Network Manager. Certainly using the Network Mgr edit UI is easy and I think I have set it correctly, but it just won't work.

I don't know if it is because I'm using TAP instead of TUN, or some other issue (difficult to test while work users are needing the connection). My Ubuntu client seems to fail to get the TAP device running or assigned an IP, but I don't know if that's just me misreading the log or not knowing the correct command to use to check properly.

EDIT: July 29 2013 I can manually connect the VPN in the terminal. The issue seems to be that OpenVPN refuses to run any "up" commands and fails to bring up the tap0 device and run assign IP address - and I've tried many, many times. So, my work around was to edit the /etc/network/interfaces to make sure the tap device will use DHCP. Then I load my "vanilla" config file from the terminal to get "initialised", and from a second terminal issue "sudo ifup tap0". The DHCP process then runs successfully and I can do my remote stuff. At the end of the session I issue a "sudo ifdown tap0" to release the DHCP and then Ctrl+C in the OpenVPN terminal.

VERY clunky, but it seems to work.

If anyone can suggest how I can get OpenVPN to successfully run the ifup command from the conf file I'd be very grateful, but please note I have already tried the following:

script-security 2

up "/home/alec/ovpn/up.sh"

where "up.sh" is a short bash script for "ifup tap0"

This (and all examples I've tried from many, many searches) gives an "(--up/--down) failure" type message that forces OpenVPN to quit.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.