Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was using Ubuntu 12.10 and upgraded to 13.04

Now Ubuntu just hangs at purple screen.

I have tried installed KDM and switched to KDM. I get the login prompt at KDM but login fails and shows up the login prompt repeatedly.

Tried many times with no success.

Using nvidia packages lightgdm nodm

What can I do to fix the problem and re-install 13.04?

share|improve this question
does the guest account work? you may just have to delete a couple files in your home folder namely .Xauthority .ICEauthority – GM-Script-Writer-62850 May 3 '13 at 6:25
I removed libatk-bridge2.0-0 using apt-get remove libatk-bridge2.0-0 I am able to boot into kde. But not gnome. This is really frustrating. I would suggest no-one should try on online upgrade – Ram May 4 '13 at 11:28

You might try this; Press F1 and get the 'Linux login' Login under your name Enter sudo useradd newuser Enter sudo addgrp newuser sudo

Enter sudo addgroup newuser sudo

Press F7 to get your GUI login and login as the new user

If it works then you can then at least know the upgrade went ok and that perhaps the .config file on your other account is messed up or maybe the .gconf is messed up. Then you could press F2, I believe that is the 'Run' command and enter gksudo nautilus or thunar or .. depending on which DE you're using. Navigate to the home directory of the messed up account and rename the .config directory to .cconfig Then try another login on the account. Hopefully it works. If not repeat the above procedure on the .gconf directory. Hopefully this will give somewhat of a starting point.

share|improve this answer
adding a new user and logging in as the new user too does not work. How do I see the X error logs – Ram May 4 '13 at 8:04
up vote 0 down vote accepted

I did the following to "solve" the issue
Reinstall the laptop with 12.10
Restored files from backup

ubuntu 13.04 is really unstable. The X does not work on my laptop at least
( Samsung NP300E5Z-A0PIN )

share|improve this answer

I got to the same point and found a way through, hope it works for you as well.

My hardware is a Gateway GT2222m with a quad proccesor and lots of RAM. Mainly using Windows I downloaded the Wubi thing to be able to switch between Win and Ubuntu 12.10 months ago. Then came the update notice prompting to update to 13.04 I accepted and it seemed fine until it hanged somewhere while updating "ubuntu docs". After that it got to the purple screen and the logo and it hanged.

So this is how i fixed it:

After reboot you are prompted to choose among windows and Ubuntu -if you have a similar install to mine- You chose Ubuntu and following comes a "GNU Grub version..." menu thing with two choices. The second one is an "Advanced options..." etc; I choose that. Then comes another menu with several lines like: "Ubuntu 13.04.xxxxx...". I choose the one top most mentioning "recovery mode" in its name. Then I came to a maintanaince Menu and chose an option named: "dpkg recover broken files". Then came a confimation box with some warnings, I accepted (like I had a choice..) an it went working. I could see it was rebuilding every file in the install and it stopped twice to ask me if i wanted to download some of them (mainly the infamous "ubuntu docs"), once it came back and told me files were not there to download so I would have to do something else later (of course no details...). I confirmed everything to go on until it was done. Took about 20 minutes but it was preety automatic. Then another warning box and I came to a terminal like mode where i should log in typing my user and password. Left with a command line I typed: sudo reboot Typed my password and the PC rebooted to normallity updated to Ubuntu 13.04

Hope it works for you.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.