Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to execute a file as a program. I own it and I ticked the box in the permissions and saved it clicked on it again it reopen the editor

How to execute it as a program as it was in Ubuntu 12.10 ?

share|improve this question

1 Answer 1

  1. First you need to check the file is marked as executable.

  2. In Raring Nautilus (the file manager) by default opens text files in gedit even if they are marked executable.

To change this From the "File" menu select preferences then the "Behaviour" Tab

Now change "Executable Text Files" to either "Run" or "Ask each time" as you prefer.

You only have to do this once.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.