Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated my 12.10 installation on a T430 thinkpad to kernel 3.5.0-28. After restarting, it would boot into grub but then hang on a blank purple screen when trying to boot with kernel 3.5.0-28. Booting with kernel 3.5.0-27 worked fine.

share|improve this question
    
I took your solution and put it in the answer as a community-wiki item so I don't get rep from it. You can mark that as an accepted answer after a while. –  Thomas W. May 2 '13 at 22:33

2 Answers 2

up vote 0 down vote accepted

(Used the OP's solution that they posted in their question and made it an answer)

When I booted into kernel 3.5.0-27, I looked at apt-get and saw that the package linux-signed-image-generic had been held back. After upgrading linux-signed-image-generic by running apt-get update and apt-get dist-upgrade and restarting, booting into kernel 3.5.0-28 works.

share|improve this answer

I had the same problem while trying to boot kernel 3.5.0-28, grub didn't launch Ubuntu and hanged on a purple screen. I started to use the kernel 3.5.0-27, it worked for one day, at the next boot, it was also giving a similar problem (hanging on a black screen this time). I solved the problem by running apt-get update and apt-get dist-upgrade, now the kernel 3.5.0-28 works fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.