Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded to Ubuntu 13.04 a few days ago.
With Ubuntu 12.10 I had set the default terminal with:

gsettings set org.gnome.desktop.default-applications.terminal exec /usr/bin/terminator
gsettings set org.gnome.desktop.default-applications.terminal exec-arg "-x"

I had set it with sudo update-alternatives --config x-terminal-emulator too.

But none of these options work on Ubuntu 13.04.

How can I set Terminator as default terminal emulator with nautilus "open terminal"?

This isn't a duplicate. As I've said: the solutions in How can I set default terminal used? doesn't work on Ubuntu 13.04 with nautilus "open terminal".
My question is: "Set Terminator as default terminal emulator WITH NAUTILUS "OPEN TERMINAL" on Ubuntu 13.04"

share|improve this question
    
Next time please mention what you've looked at already. It would help a lot. –  Seth Jun 7 '13 at 16:12
    
Next time please read better the entire question. ;-) –  Simón Jul 2 '13 at 13:09

4 Answers 4

Here's how to add an 'Open in Terminator' option:

  1. Install 'Nautilus-Actions Configuration Tool'

    sudo apt-get install nautilus-actions

  2. In 'Nautilus-Actions Configuration Tool', add a new rule with the following (as a guidance):

    • In the Actions tab, tick both boxes and select an appropriate name (e.g. Open in Terminator):

    Action (tab)

    • In the Command tab, set:
      • Path: terminator
      • Parameters: --working-directory=%f

    Command (tab)

    • In the Mimetypes tab, set:
      • Mimetype filter: inode/directory

    Mimetypes (tab)

    • Go to File > Save to save the rule and you're all set.
  3. I recommend that you also change the preferences in Nautious-Actions Configuration Tool to get rid of the two level context menu by unticking the following in Edit > Preferences:

    • (untick) Create a root 'Nautilus-Actions' menu
    • (untick) Add an 'About Nautious-Actions' item in the Nautilus context menus

    Preferences

Now you're all set and should see a 'Open in Terminator' option if you right-click in Nautilus.

share|improve this answer
sudo apt-get install terminator && sudo apt-get remove gnome-terminal && sudo ln /usr/bin/terminator /usr/bin/gnome-terminal
share|improve this answer
4  
This "fix" is a bit sloppy. –  Simón Jun 7 '13 at 13:38

This is also a bit of a 'hack', but it's less painful than the one provided by Germano, and allows you to still use gnome-terminal if you need to by referring to it with a full pathname (i.e. /usr/bin/gnome-terminal instead of just gnome-terminal).

Make sure your ~/.bashrc file contains the following somewhere in it:

if [ -d ~/bin ]; then
    export PATH=~/bin:$PATH
fi

Then run the following in a shell:

mkdir -p ~/bin
ln -s /usr/bin/terminator ~/bin/gnome-terminal

Finally, log-out, and back in to your Ubuntu account.

share|improve this answer

EDIT: Just saw this meaning it maybe does not work with 13.04 after all. Still, it is something I would try (I'm on 12.04 LTS btw): Setting nautilus-open-terminal to launch Terminator rather than gnome-terminal

Original Message:

It may be too late, but since I was looking for a solution to the same thing but for konsole...

If you install dconf-editor you can (very similar to the gsettings commands) set the terminal you want to have opened by opening dconf-editor and setting:

org->gnome->desktop->applications->terminal->exec = terminator
org->gnome->desktop->applications->terminal->exec-arg = -x

Afterwards you can quit and re-initialise nautilus with nautilus -q (may take two executions for the following to appear)

$ /usr/bin/nautilus -q
Initializing nautilus-gdu extension
Initializing nautilus-open-terminal extension
Shutting down nautilus-open-terminal extension
Shutting down nautilus-gdu extension

It's also now possible to debug nautilus from the command line with:

$ /usr/bin/nautilus
Initializing nautilus-gdu extension
Initializing nautilus-open-terminal extension
...
...

Any problems when calling 'Open in Terminal' will be logged here.

NOTE: this was only possible directly after calling with the -q flag. Otherwise calling nautilus simply opens the application and returns to the shell without logging.

My problem, if it interests anyone, was that the -x arg doesn't work with konsole, so I changed it to --new-tab -e because I didn't want a new Konsole window opening up everytime.

Hopes it helps someone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.