Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I set export UNITY_LOW_GFX_MODE=1 in my ~/.xprofile and it no longer has any effect in 13.04. Is there a way to disable all the eye candy? I'm running in VirtualBox and the Unity 3D mode with all the visual effects is overwhelming for the VM. Unity works and is usable, it's just very slow to render, so I'd rather have it off (is this 2D mode?).

share|improve this question
add comment

3 Answers

up vote 6 down vote accepted

Especially on a low end machine such as mine (Athlon dual core, GForce 210) running Ubuntu with Unity and Compiz enabled is quite a challenge and may result in a rather slow and sluggish experience.

Virtual machine settings

To improve this I gave the following settings to the virtual machine:

  • enable VT-x/AMD-V, Nested Paging
  • 2 CPU (from dual core host) with an execution cap at 90% to ensure host operability
  • 2048 Base Memory
  • 256 MB Video Memory

    VBoxManage modifyvm "Name of VM" --vram 256
    
  • 3D Acceleration enabled

  • Guest Additions installed

Remove desktop effects

Then I observed a very slow animation for windows and menus. This animations did more harm than use in my virtual machine. Below is three methods how to disable them to get a smoother experience in Virtual Box:

Unity Tweak Tool Install unity-tweak-tool

This awesome application lets you disable animations in the Window Manager/General settings dialog:

enter image description here

Compiz Config Settings Manager Install compizconfig-settings-manager

As this is a virtual machine with the option to make a snapshot before you do harmful things to your OS you may probably safely runs ccsm to disable Compiz effects:

enter image description here

Do not disable windows decoration above

Dconf Editor

Lastly here is how to do it with dconf-editor:

  • Browse to org.compiz.profiles.default.core and remove the following from active profiles:

    'animations' 'fade'
    
  • Browse to org.compiz.profiles.unity.core and remove the following from active profiles:

    'animations'
    

Unfortunately I have found no way to disable the Dash animation, which still will be rather slow.

GNOME Session Flashback Install gnome-session-flashback

In the likely case you are still not happy with the overall speed of the desktop you may consider installing the GNOME Session Flashback, which will let you log into GNOME Flashback (Compiz or Metacity) with a lean and fast desktop reminiscent of 10.04, but with all the upgraded applications, and the recent kernel:

enter image description here

enter image description here

enter image description here

share|improve this answer
    
Incredibly helpful thank you so much!!! –  Mark Richman May 3 '13 at 13:01
    
unity tweak tool can be install be typing, in a termianal: "sudo apt-get install unity-tweak-tool" –  Tom Jul 10 '13 at 13:37
add comment

There are known issues with virtualbox and unity which does not allow unity 3D to function properly as expected ( when you don't have Graphics card). Try using different Desktop like Cinnamon or Gnome. or just disable 3D from Vbox settings.

share|improve this answer
add comment

Just enable 3d and increase VRAMSize to 256 mb, i followed this article from nam huy and it works. I really don't like unity though, if you dont really need to use unity (ubuntu), you should switch to xfce or lxde, much lighter and faster.

share|improve this answer
1  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Kevin Bowen Sep 16 '13 at 8:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.