Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Optimus laptop running Raring and now I'm using nvidia 304 drivers, which have bad performance and some games are not working properly (e.g. Oil Rush is working properly only with 319, with older drivers I have a problem with lighting, so the game is unplayable)

So is there a way how to run bumblebee with Nvidia 319 downloaded from Nvidia website? I know about Bumblebee config, but I don't know what should I edit in it.
Thanks for help.

share|improve this question
    
    

2 Answers 2

up vote 8 down vote accepted
sudo add-apt-repository ppa:xorg-edgers/ppa 
sudo apt-get update
sudo apt-get install nvidia-319 nvidia-settings-319 

Then edit bumblebee.conf

 sudo nano /etc/bumblebee/bumblebee.conf

It should have this lines:

# You need to explicit the driver used by Bumblebee server.
Driver=nvidia

KernelDriver=nvidia-graphics-drivers-319
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-graphics-drivers-319:/usr/lib32/nvidia-graphics-drivers-319
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-graphics-drivers-319/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

Restart the bumblebeed daemon using the following command:

 sudo service bumblebeed restart

Just install & tested its working fine

optirun glxspheres

Bumblebee-Project

WEBUPD8


optirun -vvv glxspheres 
[ 1385.959123] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 1385.959847] [INFO]Configured driver: nvidia
[ 1385.960226] [DEBUG]optirun version 3.2.1 starting...
[ 1385.960269] [DEBUG]Active configuration:
[ 1385.960281] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 1385.960292] [DEBUG] X display: :8
[ 1385.960302] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-319:/usr/lib32/nvidia-319
[ 1385.960313] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 1385.960323] [DEBUG] Accel/display bridge: auto
[ 1385.960333] [DEBUG] VGL Compression: proxy
[ 1385.960343] [DEBUG] VGLrun extra options: 
[ 1385.960354] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[ 1385.960419] [DEBUG]Using auto-detected bridge virtualgl
[ 1388.086427] [INFO]Response: Yes. X is active.

[ 1388.086477] [INFO]Running application using virtualgl.
[ 1388.086729] [DEBUG]Process vglrun started, PID 3491.
Polygons in scene: 62464
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: GeForce GT 525M/PCIe/SSE2
94.087784 frames/sec - 102.571552 Mpixels/sec
104.808515 frames/sec - 101.916638 Mpixels/sec
105.079375 frames/sec - 102.180025 Mpixels/sec
105.155037 frames/sec - 102.253599 Mpixels/sec
[ 1397.201911] [DEBUG]SIGCHILD received, but wait failed with No child processes
[ 1397.201986] [DEBUG]Socket closed.
[ 1397.202029] [DEBUG]Killing all remaining processes.
share|improve this answer
    
have you tried this? because it ended up with; 01:51 ~ $ primusrun glxspheres primus: fatal: Bumblebee daemon reported: error: Could not load GPU driver –  jeffisabelle May 3 '13 at 22:57
    
removing bumblebee, nvidia drivers, and reinstalling them worked as explained here; askubuntu.com/a/288716/18309 –  jeffisabelle May 3 '13 at 23:45
    
have you check the link webupd8.org/2012/12/use-nvidia-experimental-drivers-310.html –  Qasim May 4 '13 at 2:35
    
yes I do, I had install 310 drivers from there, but it didn't work for 319 somehow. this driver issues makes me sick, I never had success even for once at first try. –  jeffisabelle May 4 '13 at 8:55
    
just wait few more months nvidia optimus will be here soon, then you do not need bumblebee –  Qasim May 4 '13 at 8:59

For most people, we are downloading Nvidia 319 from xorg-edgers. Thus, the configuration SHOULD be,

driver=nvidia
KernelDriver=nvidia-319
LibraryPath=/usr/lib/nvidia-319:/usr/lib32/nvidia-319
XorgModulePath=/usr/lib/nvidia-319/xorg,/usr/lib/xorg/modules`

The trick to making this work, is there is a Driver= not only in the [driver-nvidia] section of the config file, but also at the beginning of the config file. Make sure both say Driver=nvidia.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.