Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When trying to run the ./configure for gtk+-3.6.4 I get the following:

Requested 'glib-2.0 >= 2.35.3' but version of GLib is 2.34.0

Requested 'atk >= 2.7.5' but version of Atk is 2.4.0

Requested 'pango >= 1.32.4' but version of Pango is 1.30.0

Requested 'gdk-pixbuf-2.0 >= 2.27.1' but version of GdkPixbuf is 2.26.1

I downloaded the latest tars and installed them all with ./configure && make then as root make install without an issue, but the problem persists.

I'm running a fresh installation of 12.0.4.2 64bit with all other updates performed before I even started trying to install GTK3.6.4.

share|improve this question
    
Is there any specific reason why you need 3.8.1? –  thefourtheye May 2 '13 at 15:59
    
Got mixed up and meant to say 3.6.4 (both times), sorry. Was reading about it and happened to type what else was on my mind. –  Curtis May 2 '13 at 16:10
    
Which os you are using –  Qasim May 2 '13 at 16:16
    
Ubuntu 12.0.4.2 64bit. @thefourtheye Need GTK+3.6.4 for DeSmuME 0.9.9. –  Curtis May 2 '13 at 16:19
    
In Ubuntu 13.04 GTK 3.6.4-0ubuntu8 is already installed –  Qasim May 2 '13 at 16:19
show 2 more comments

1 Answer 1

In your Ubuntu 12.04 installation, add a software repository from (12.10 or 13.04) that contains already the debian package for gtk 3.6.4

Then force that highest version for your gtk-package. And lock it, so it will not be updated.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.