Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running an Ubuntu image provided by my company, it seemed to have some strange locale settings to begin with. Firefox uses the French dictionary by default and I get warnings when doing anything with SSH (git pull/push and normal SSH sessions).

Those warnings look like this:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_PAPER = "en_GB.UTF-8",
        LC_ADDRESS = "en_GB.UTF-8",
        LC_MONETARY = "en_GB.UTF-8",
        LC_NUMERIC = "en_GB.UTF-8",
        LC_TELEPHONE = "en_GB.UTF-8",
        LC_IDENTIFICATION = "en_GB.UTF-8",
        LC_MEASUREMENT = "en_GB.UTF-8",
        LC_TIME = "en_GB.UTF-8",
        LC_NAME = "en_GB.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

I have been trying to set my locale to en_GB.UTF-8 using information I have found on places such as askubuntu.com but I can't get it to work. My current /etc/default/locale file contains the following.

LANG="en_GB"
LANGUAGE="en_GB:en"

And here is the result of my locale command.

LANG=en_GB.UTF-8
LANGUAGE=en_GB:en
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC=en_GB.UTF-8
LC_TIME=en_GB.UTF-8
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY=en_GB.UTF-8
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER=en_GB.UTF-8
LC_NAME=en_GB.UTF-8
LC_ADDRESS=en_GB.UTF-8
LC_TELEPHONE=en_GB.UTF-8
LC_MEASUREMENT=en_GB.UTF-8
LC_IDENTIFICATION=en_GB.UTF-8
LC_ALL=

Does anyone have any idea what can be set to correct this?

Thanks.

share|improve this question
    
I think I might have fixed it by stopping my client sending my locale settings to the external server. Found in this answer. Need to try some things to make sure though. –  Wolfy87 May 2 '13 at 9:54
add comment

1 Answer 1

Try adding this line: en_US.ISO-8859-1 ISO-8859-1 to this file: /var/lib/locales/supported.d/en. Then run dpkg-reconfigure locales in the command line.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.