Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to get this wireless card using Broadcom BCM5751 chipset working, but it is just giving me frustration. This is using the tg3 module.

What have I tried so far:

  • Play around with the default kernel module. Yes, it shows the available wireless networks but will not connect. I'm currently in net through wired connection, using the same tg3 module.

  • Download the linux driver from Broadcom's website. The package comes with .rpm and .tar.gz drivers, no .deb. Extracted the .tar.gz, and followed the README. Tried to compile the driver, but compile fails.

  • Installed ndiswrapper and downloaded windows drivers (tried with Vista and XP). Result:

    sudo ndiswrapper -l
    b57nd60x : invalid driver!
    b57win32 : invalid driver!
    
share|improve this question
    
We're confused. Your question is titled for a wired ethernet device but the text of your question seems to involve wireless. Which is it? What is your wireless device? lspci -nn | grep 0280 –  chili555 May 2 '13 at 12:31
    
I did not notice your message earlier. The question is for USB Wifi key with the mentioned chipset. My question title seems a copy-paste error. I already discovered that there is no driver for that chipset, and decided to look for another wireless USB adapter. –  Ossi Viljakainen Jun 19 '13 at 21:55
    
There is no USB wireless device with the above mentioned chipset. –  chili555 Jun 20 '13 at 13:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.