Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a premium Spotify account and wish to use this account via the Clementine Music Player 1.1.1. program. But when I go to the Configure Spotify tab in that program, the plugin is stated as not installed and there's also no option to do so.

Can you please advise?

share|improve this question

3 Answers 3

I Finally got the plugin to be recognized by Clementine.

Adding to coteyrs answer, here is what I did:

  1. Create the folder where the plugin will be placed

    mkdir -p ~/.config/Clementine/spotifyblob/version14-64bit
    
  2. Download the plugin

    cd ~/.config/Clementine/spotifyblob/version14-64bit
    wget http://spotify.clementine-player.org/version14-64bit/blob
    wget http://spotify.clementine-player.org/version14-64bit/libspotify.so.12.1.45
    
  3. Make sure the executable bit is set on the blob

    chmod +x blob
    
  4. The blob was looking for libspotify.12, so we create a symlink

    ln -s libspotify.so.12.1.45 libspotify.so.12
    
share|improve this answer

Direct from the clementine site..

You can download the latest version of Clementine on Ubuntu from the official PPA.

Run these commands in the terminal:

sudo add-apt-repository ppa:me-davidsansome/clementine
sudo apt-get update
sudo apt-get install clementine

You will need to do this if you want the latest (or non-open) features.

Once you have updated if your still missing the plugin download button you can install manually. Instructions are here. You can download the plugin from this directory. Just put the blob and the plugin in ~/.config/Clementine/spotifyblob

share|improve this answer
1  
Hi thanks for the reply. I have the latest version of Clementine and have run the commands you suggested but the option to install the plugin is still not there. –  Rob Mather May 2 '13 at 20:22
1  
There is a download button for me. Clicking this button allows me to download see dl.dropbox.com/u/18875117/Preferences_074.png –  coteyr May 2 '13 at 20:53
    
Is that 1.1.1 and are you in ubuntu 13.04? If so then I'. At a loss. No plugin option on mine :-( –  Rob Mather May 2 '13 at 22:31
    
make the preferences window bigger? Maybe it is cut off? –  coteyr May 3 '13 at 11:55
    
No, even fullscreen it's not there... ubuntuone.com/3IhnyeIqqekFh5Y1nocLYL –  Rob Mather May 3 '13 at 13:25

This is the fix! http://xeizo.com/blogg/?p=563

Download from here and the Install Spotify plugin will be enabled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.