Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just install tmux on Ubuntu 12.04 LTS and it throws me this error when I try to use tab completion for simple commands like 'cd' or 'mv' in the /etc/bash_completion file.

command substitution: line 74: syntax error near unexpected token `done'

However, I can use tab completion in my normal terminal or in byobu. Has anyone else encountered this issue or knows how to fix it? I do have the bash completion file included in my .bashrc.

share|improve this question
up vote 0 down vote accepted

I had the similar question, until I found this.

http://blog.e-thang.net/2012/08/14/tmux-and-bash-tab-completion/

Pretty good, colorful, explanation.

Reference:

  • /usr/share/byobu/keybindings/f-keys.tmux

  • /usr/share/byobu/keybindings/f-keys.tmux.disable

share|improve this answer
2  
Link says This Account Has Been Suspended. Ouch. – IsaacS Feb 6 '15 at 23:40
    
[recovered from cachd web page] Somewhere along the Ubuntu 12.04 LTS, tmux, bash development chain someone decided to add this little gem of a key binding: bind-key -n Tab clear-history They mapped that to clear the history, shutting down whatever else it may have done. This one is SO ODD, that I can only imagine there was some really good and crazy reason for it. To overcome this “feature” add the following to your .tmux.conf. unbind -n Tab – Alessandro Cuttin Feb 10 '15 at 14:45
    
Booo, thanks for the assist, @AlessandroCuttin – IRTermite Jun 25 '15 at 21:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.