Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

3 days now I have not been able to boot my computer to my OS due to a black screen. Wow, and I really did love this OS at one time. I'VE BEEN TRYING TO GET PASS THE BLACK SCREEN SINCE YESTERDAY MORNING. CAN SOMEONE AT LEAST TELL ME HOW TO GET IT UP? SO I CAN AT LEAST SEE THE SCREEN AGAIN? I NEVER HAD ONE PROBLEM WITH 12.04 UNTIL I HIT 12.04.2 AND 13.04. I've never had this problem until recently and don't know if it has something to do with Ubuntu being on a SATA HDD and LinuxMint 14 on a IDE HDD.

When I move my mouse to awake the computer, the monitor light goes from orange to blue so I know the monitor comes on - however the screen is solid black. Sometimes when I restart I watch my HDD light when it stops blinking. I'm guessing its at GRUB menu so i press Enter, then it will come to my first option to allow to sign in which I can see, and sometimes it doesn't. I have HDMI, but I'm running DVI. I can't see my first option in GRUB, I just press Enter, and then I see my sign in screen.

After several times of pushing the restart button on my computer it finally comes up, but it takes quite a few tries.


When I am on LinuxMint HDD, the same thing happens there as well.
I have a Radeon HD 6500 graphics card and tried several different drivers (open source and proprietary), but nothing fixed it. I am now using AMD Catalyst 13.4 driver, which works great, except for this issue.

I've researched Google and tried a few things but nothing works and this is getting very old fast.

Does anyone know how to fix this?

If the computer goes to sleep and I wake it within 3 minutes, it comes up fine, with no issues, but if it goes to sleep for awhile, an hour or so, it has this issue.

I am using the 3.5.0-28-generic kernel as well as the newest quantal x stack.

Checking my BIOS - I am already set to "s3". I'm not really sure I want to suspend to hard drive since suspend to ram was working. I have also tried the "acpi_sleep=old_ordering" trick in Grub boot options to no avail.

To add to this, when I added LinuxMint, on second HDD I unplugged my SATA HDD from computer that had Ubuntu on it, then installed LinuxMint 14 on the IDE HDD. Once installed, I then plugged my SATA drive back up and ran sudo update-grub.


As I've been reading more on Ubuntu 12.04.2, I wonder if when my kernel and xorg stack updated to quantal if this is my issue... Is there a way to roll back to an older kernel to test this? I can't remember correctly right now, but this issue might have started when I put LinuxMint 14 on the IDE HDD and thats equivalent to Ubuntu 12.10, right? Could this be the issue? The new xorg and kernel? Although my boot priority in BIOS loads my SATA drive which has 12.04 Ubuntu on it first anyway, but also has been updated to the new quantal kernel. I set a link here to my xorg file, hoping it might help some as well.

Update 1:

I just tried to run memtest from Grub menu, and I get an error "too small lower memory (0x99100 >0x99800)". The test doesn't start and I have 2 entries of memtest in Grub2. I am running 8gigs of ram, gigabyte socket 775 board, quad-core setup. I'm not having any crashes, my memory shows up in system monitor.
I've just researched this issue. Seems its a bug, but would it affect my S3 setting in BIOS?

Update 2:

Just switched from S3 to S1. It Doesn't work neither.
I've noticed in my xorg log file that I'm receiving some errors

(EE) open /dev/dri/card0: No such file or directory,,,,,
(EE) open /dev/fb0: No such file or directory,,,,,
(WW) Falling back to old probe method for fglrx,,,,,,,
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found,,,,,,,
(WW) Falling back to old probe method for vesa,,,,,,,,
(WW) Falling back to old probe method for modesetting,,,,
(WW) Falling back to old probe method for fbdev,,,,,
(WW) fglrx(0): board is an unknown third party board, chipset is supported......

I have also upgraded to 13.04 and still fighting this issue. I've tried nomodeset in Grub and yet [nothing is working](my xorg.conf).

Update 3:

Today, as usual, when my computer rebooted and came back up, I couldn't see anything but a black screen. Not even BIOS or Grub. However, I assumed that Ubuntu was highlighted in the Grub and pressed Enter. Then I see my HDD light lit up, then hear the Ubuntu chime. I attempted several reboots, for about 30 minutes. Then I become frustrated on last attempt and did this - while my computer was running I unhooked my DVI cable from the graphics card and then hooked it back up. And all of a sudden I no longer had the black screen. I could see my desktop finally. Does this help anyone out there to help me fix this issue?
Another thing I've noticed is my LinuxMint HDD is /sda1, while my Ubuntu SATA HDD is /sdb. Should the Grub be on /sda1?

syslog

This is my syslog picture.

share|improve this question
1  
If you have a good backup of you computer it may also be worth investigating whether the newer raring kernel which has just been added to 12.04 repos works better: linux-image-3.8.0-19-generic - NOTE I cant emphasise enough - make sure you have a image backup just in-case this leaves your computer not bootable. –  fossfreedom May 8 '13 at 20:33
    
Power management comes to mind, I would try disabling ACPI first. if that does nothing, then one might guess modules, but you say youve done this. So next you will want to look at the process, that puts your computer to sleep, looking for crashes, hangs, or errors. So what process(es) happen when hibernate happens? –  j0h May 10 '13 at 1:07
    
@robert try this askubuntu.com/questions/292878/… –  Qasim May 10 '13 at 2:30
    
I have similar symptoms with my monitor as described in Update 3. Next time you might want to try to completely pull the power plug from your monitor and plug it back to see if it comes alive. –  lgarzo Jul 10 '13 at 17:03
    
Ive tried that but thank you for commenting I think next im going to light a fire and thro the ubuntu symbol into it as i chant to the happy godz with panties around my head...I heard that might be an option –  robert Jul 11 '13 at 0:00

4 Answers 4

I have experienced this issue many times with windows let alone ubuntu, Mint, Debian and the like. I tend not to use suspend for this reason, but it has worked on Ubuntu 12.04 and earlier for me, but is highly dependent on your motherboard and video card.

The first thing you must do which you have done is make sure suspend to RAM (S3) is enabled in the motherboard BIOS. Following on from that in the motherboard BIOS ensure that hard drive spindown is disabled and DPMS is enabled (also try disabling this if it is enabled, that is if the option is in the BIOS).

Also ensure if the option is available, set the 'Plug 'n play operating system installed' set to YES. Recently on Ubuntu I stopped using the ATI and Nvidia drivers and use the Ubuntu one as I found them buggy, booting to a black screen, no desktop and constant crashing. It helps some times to list out the hardware ie motherboard, RAM, Power supply, video card as it can give an idea of a buggy ACPI setup in a BIOS which can be resolved with a BIOS update or slightly incompatible components.

share|improve this answer
    
I thank you for your suggestions but I had never experienced this issue til around I think 2 weeks ago.I started with ubuntu 11.10 and up thru 12.04.I had been on 12.04 quite a long time then all of a sudden I get this issue,Im just not thinking it s my hardware.I had been using open source ubuntu driver for my graphics card forever-this is the driver this issue started happening with.I loaded proprietary hoping to resolve issue and found the proprietary better in ways but still this issue.I have however tried your suggestion but to no avail-I thank you thoo very much it crosses off more areas –  robert May 8 '13 at 18:30

This will occur rarely in dual boot. First you have to identify whether your display settings are same as that your display(15.6 or 13.6..etc..,) has in Ubuntu, After that check out Display adjustment and how many displays are present over there. After all these check-ins u will get your normal screen as earlier you have.

share|improve this answer
1  
could you give me a step by step on how to check the display settings out to see if they match?In display settings my resolution is 1680x1050(16:10) what am I checking this against or where do I need to go to see if it matches?In catalyst it shows 1680x1050 but not (16:10) is that what your referring to?my catalyst settings to display settings in ubuntu? –  robert May 5 '13 at 15:15
    
yeah i mean both of them are referred as Display settings. First you must go through the Ubuntu Display settings and this will be available at System settings. And after that you have to identify how many screens are present in your Ubuntu(that option was provided over there). and finally after setting all these fields now you have to set you catalyst. More: If you want to change your window color then (change window color) one option is provided at Display Settings it self. –  SiyanShiva May 7 '13 at 2:01
    
@SiyanShiva-I finally went to your profile to check questions you had concerns with-I appreciate your answer but I dont feel it s helpful here no offense –  robert May 7 '13 at 13:32
    
@robert i am sorry for that.., i faced this problem earlier so that's why i gave you all the possible solutions which gives maximum results to getting solve your display problem. But unfortunately it seems doesn't working with your configurations i think, and that is not my fault. And thank you for giving such valuable feedback Mr.robert –  SiyanShiva May 7 '13 at 13:59
    
you are very welcome and I thank you as well for your knowledge I m sure it will come in handy somewhere along the lines –  robert May 7 '13 at 14:04

I'm going to put in my two cents. I have a similar setup, Ubuntu 12.04LTS, and Debian 6. I just checked my BIOS, and the settings are below:

ACPI Function Enabled
ACPI Standby State S1

I have Ubuntu and Debian both with the latest updates as of 5/10/2013. I use mostly Ubuntu, and sometimes it goes to sleep for days. But no matter how long it sleeps, it always wakes up with no problems. I have ATI (AMD)Radeon Graphics, with the latest AMD Catalyst 13.4 Proprietary Linux x86 Display Driver.

As I mentioned I have mine set to S1, and since you have yours set to S3, with deals with RAM, I would suggest that you set your ACPI to S1, test your RAM, and maybe see if there is a BIOS update to your system board.

share|improve this answer
    
Ive checked for a bios update from manufacturer but from what I read it isnt an update worth flashing for.However I have set my ACPI to S1 if this resolves the issue I ll accept your answer although I feel if it has always been set to S3 and worked before if I can just make it work somehow Im happy –  robert May 10 '13 at 13:57
    
Update the bios anyway, they may have fixed a bug without putting it in the changelog. –  Yet Another User May 10 '13 at 15:13

Same problem on my laptop. I made it work but i don't know if this will help you, but you can try. This is most known on intel vgas but on the reference link there are something about ati and nvidia to.

Force Pipe A Quirk This problem typically exhibits itself on Intel graphics hardware (most particularly i855) by locking up the machine when closing the lid. The fix for this issue is to quirk your card to force enabling Pipe A. If you suspect you're having this bug, try setting this option in your xorg.conf:

 Section "Device"
     ..
     Option "ForceEnablePipeA" "true" EndSection

Fore more reference visit the source of the above quote:

https://wiki.ubuntu.com/X/Quirks#Force_Pipe_A_Quirk

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.