Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a fan of Ubuntu products and not the newest in dealing with its Desktops and servers, but i have come across a huge problem. When Ubuntu 13.04 came out and claimed it supported UEFI, i immediately got it for my laptop, and Asus K55N. I tried to install it by manualy selecting the swap, BIOS, and root partitions so i can keep it organized with Windows 7 Home premium. So after it finished installing, when i rebooted, it said there was no boot-able device installed. I assumed it was because of UEFI so i disabled it and still there was no booting option. I then looked on-line and tried Boot repair on the LiveCD but none of it worked. I am out of ideas and i need help. If anyone can find a way to fix this without deleting Windows 7 or its files, i will be grateful.

Here are my partitions:

/dev/sda1 ntfs 172854MB Windows 7(loader)  (my C: drive)

/dev/sda2 ext4 296351MB Ubuntu 13.04 (my D: drive)

/dev/sda3 ntfs 26843MB Windows Recovery Environment (loader)

/dev/sda4 biosgrub 148MB

/dev/sda5 swap 195MB

again any help would be appreciated, thank you.

share|improve this question
    
What does this script tell you; use pastebin to hold it; UEFI should not be a problem for any OS, as long as the system did not ship with windows 8 –  GM-Script-Writer-62850 May 2 '13 at 0:59
    
here is the result pastebin.com/eWg49pJW –  Samuel Kebadu May 2 '13 at 2:02
    
The only thing i see out of place is /dev/sda6 there is something wrong with it, it looks to be a second swap partition but seems broken, sda5 appears to be a good swap partition, can you get a screenshot of gparted? If it is a swap partition delete it and grow /dev/sda5 to fill that space, you can try reinstalling grub sudo grub-install /dev/sda4 –  GM-Script-Writer-62850 May 2 '13 at 2:29
    
ok i see what you mean, but first here is the gparted screenshot i took incase you need more info before we change anything,how do you upload an image to the question? –  Samuel Kebadu May 2 '13 at 10:27
    
ok well i did try to install the grub on /dev/sda4 and here are my results pastebin.com/sRtFNazi –  Samuel Kebadu May 2 '13 at 11:01
add comment

1 Answer

When I did a dual-boot install of Ubuntu 12.10 it insisted that my options were to either wipe the XP install and install on the internal drive, or it would set up the dual-boot install on my USB hard drive, so I let it do the second option.

I then found that (suspect) the grub loader startup was very dependent on the USB devices enumerating exactly as they were when it installed. If there was any change to the USB lineup, e.g. a thumbdrive plugged into the USB hub, the system was dead, but put it back like it was at install and all was good.

The symptom sounds kinda' like yours, tho' I'm not sure your linux partition is on a USB device. I'm thinking not? Thought I'd toss it out.

Benton 1may30

Epilogue: a month later my XP install became unbootable for reasons unknown, but I was able to mount the NTFS drive with Linux and copy everything I wanted off to another drive, then re-ran the install, this time wiping XP. XP's going EOLife in a year, didn't seem worth trying to recover it...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.