Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Dell Inspiron N4010 laptop. My brightness hotkeys are not able increase or decrease the brightness of the screen. And as a matter of fact, I also can not reduce the brightness from the Brightness & Lock menu under System Settings. Any solutions?

EDIT: I think I may have found the reason behind the problem. In the previous versions of Ubuntu there were acpi_video0 and intel_backlight inside the /sys/class/backlight folder. Now in 13.04 there are dell_backlight and intel_backlight in that folder. And the most interesting part, my friend installed 13.04 on his Dell Vostro and in his system's /sys/class/backlight folder there are acpi_video0 and intel_backlight. So the brightness hotkeys are working for him.

share|improve this question
up vote 3 down vote accepted

I have the same model and I had the same problem all the way through 13.04 development until one day before release and then it started working. I filed the bug here: Bug #1105604: Brightness control stopped working

What you can do is to use a manual override that I used throughout development, by modifying /etc/rc.local as follows:

#!/bin/sh -e
# rc.local
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
# In order to enable or disable this script just change the execution
# bits.
# By default this script does nothing.
echo 978 > /sys/class/backlight/intel_backlight/brightness
chmod 777 /sys/class/backlight/intel_backlight/brightness
exit 0

The downside is that you can't change the brightness easily except by manually modifying the file /sys/class/backlight/intel_backlight/brightness

When I did have it working, I used the Fn + brightness keys to check the settings: the lowest setting is 490 and after that it goes up in increments of 488. So these are the default settings for /sys/class/backlight/intel_backlight/brightness:

490 Lowest with backlight on
4882 Brightest

My brightness controls were previously working, but are broken again so I decided to create a script to manage it:

# Dell N4010 brightness control workaround
# Note: add the following to /etc/rc.local
#       chmod 777 /sys/class/backlight/intel_backlight/brightness
# For convenience I've assigned the keys Alt-Up and Alt-Down to run this script
# Fine tune the bump parameter as required
# Usage:
#    ./ up   # bump up brightness
#    ./ down # bump down brightness
curr=`cat /sys/class/backlight/intel_backlight/brightness`
if [ "$1" == "up" ]; then
  curr=`echo "$curr + $bump" | bc`
  curr=`echo "$curr - $bump" | bc`
# Set the brightness to the new level making sure it's always above 30 (minimum usable)
if [ $curr -gt 30 ]; then
    echo $curr | tee /sys/class/backlight/intel_backlight/brightness

Note: I added a line in /etc/rc/local to give me authority to the brightness file:

chmod 777 /sys/class/backlight/intel_backlight/brightness

Then I assigned it to the keys Alt+Up and Alt+Down as shown here:

enter image description here

share|improve this answer
Awesome!! Works like a charm! – user152748 Sep 8 '13 at 16:17

Ok, so here's the solution I found. This command is the only way in which I can change my Laptop brightness.

echo X |sudo tee /sys/class/backlight/acpi_video0/brightness

Where "X" is any number between 1 and your laptop max_brightness capacity. Here's How you can find that number:

cat /sys/class/backlight/acpi_video0/max_brightness

In my case, is a range bettween 1 and 7. So I just created an alias for every level of brightness. In a way that

echo 3 |sudo tee /sys/class/backlight/acpi_video0/brightness

Is now:


Note: I added the 'z' so I can just write 'zb' and then press tab, to make things faster.

Anyway, Is probably not the most effective solution, but It sure works well for me. If you're not afraid of the terminal, it should work just fine for you as well.

try this as well


sudo gedit /etc/default/grub

Update these lines:


with the following arguments:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor" GRUB_CMDLINE_LINUX="acpi_osi=Linux"

Then run sudo update-grub and reboot.

share|improve this answer
Thanks for the help :) But sorry to tell you that editing the grub file doesn't solve the problem. And creating aliases is a great idea! – user152748 May 2 '13 at 12:14
I have Dell Inspiron 7520, this solved my problem, but the system became unstable. The brightness controls had some delay before actually changing the brightness, also when I pressed some brightness button the reaction was as if I pressed it twice. When I pressed those buttons quickly and chaotically the system could stuck, the mouse pointer speed reduced and the KDE even logged me off. So very weird behavior. – Vic Mar 4 '14 at 8:16

I've had the same problem. The brightness slider didn't work, nor did the hotkeys. So I wrote a small panel indicator which could adjust brightness. But you will have to add write permissions to the /sys/class/backlight/intel_backlight/brightness file. Here are the steps if you are interested.

Download the app indicator source from here: indicator-brightness

  1. Make sure that the brightness can be adjusted using intel_backlight by using the following method
    • echo 1000 | sudo tee /sys/class/backlight/intel_backlight/brightness and enter password
    • If your brightness changes, continue to step 2.
  2. Change permissions for the /sys/class/backlight/intel_backlight/brightness file by
    • Open the /etc/rc.local file sudo gedit /etc/rc.local
    • Add the chmod command above exit 0 : chmod 777 /sys/class/backlight/intel_backlight/brightness
  3. Move the to /usr/bin mv /usr/bin/
  4. Make the file executable. sudo chmod +x /usr/bin/
  5. Add the command to Startup Applications

You don't really have to move it to /usr/bin but I found it easy to access the file from there.

Note: I borrowed the brightness step values from bcbc's answer above. I have also posted some screenshots in my blog if you want to see how it looks : blog

share|improve this answer

Solution given at following link worked for me:

Brightness keys F4 and F5 not working on Dell XPS 15.6 Laptop

My Configuration is as follows:

OS: openSuse 12.3 (Dartmouth) Desktop: KDE 4.10 Laptop: Dell Inspiron 15

Note: Although solution proposed to run command 'update-grub' but I couldn't run as it was not found on the system. Fortunately, even without running this and rebooting the system fixed these keys. Now, I am able to adjust the brightness using F4 and F5 Keys in functional mode. You can also use following command to adjust it (specific case as mine)

$ echo x > /sys/class/backlight/dell_backlight/brightness

Where x varies from 0 to 15.

share|improve this answer

I just fixed my backlight following the instructions from the Ubuntu Wiki In my case what worked was creating the file /usr/share/X11/xorg.conf.d/80-backlight.conf with the following config:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"     "sna"
    Option      "Backlight"       "intel_backlight" # use your backlight that works  here
    BusID       "PCI:0:2:0"
share|improve this answer

protected by Community Dec 25 '14 at 10:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?