Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two NICs within my Ubuntu server. One being the internet, the other being an internal network. I have the following configuration whereas eth0 is the internet, eth1 is the internal network

auto lo eth0 eth1
iface lo inet loopback

iface eth0 inet dhcp

iface eth1 inet static
address 192.168.1.21
netmask 255.255.255.0

Eth0 works correctly and I cannot connect via the internal IP. Both eth's are up. Thanks.

share|improve this question

migrated from stackoverflow.com May 1 '13 at 16:46

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer 1

I assume that you want to be able to access the Internet from machines on 192.168.1.0/24 and you want 192.168.1.21 to serve as a gateway for those machines which I also assume are connected to a switch which has an uplink to your gateway's eth1 interface.

I don't see you mention a couple of things: 1. NAT functionality being configured 2. IP forwarding enabled 3. Other appropriate firewall rules added 4. DHCP server running on eth1 assigning IP configuration to your internal machines.

If you confirm my assumptions and let me know what the state of those 4 components is, I'll update my answer and help you set it up.

PS. Let's say that you have a machine with the IP address 192.168.1.50 connected directly to your server's eth1. Are you able to ping 192.168.1.21 from it?

share|improve this answer
    
Hi Martin. Thanks for your answer, but after many hours of fiddling around with settings, it looks like it is some hardware failure on eth0. Also, the reason for the duplicate is because I asked on StackOverflow first, then it automatically migrated to here. Thanks. –  James Elliott May 2 '13 at 11:01
    
Hi James, I was suspecting that this was the case after finding the information that it's been migrated. BTW: have you tried testing your NIC with ethtool -t? –  Marcin Kaminski May 2 '13 at 16:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.