Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Am I able to install a lens or a scope in 13.04 that I had used before in 12.04? Are the lenses and scopes build earlier (What lenses are available for Unity?) able "to just work" on 13.04?

Looking forward to Recoll Lens & News Lens again if this is the case that what has worked will work just the same on 13.04.

Thank you for your time and answers.

share|improve this question

1 Answer 1

Quoting from the Ubuntu Meeting Log:

67 [17:27] pawel_st asked: ​ is lens/scopes api stable/going to be stabilized with 12.04; will backwards compatibility be maintained from now, or is it still a moving target?

68 [17:28] the lens API had to be changed between Oneiric (11.10) and Precise (12.04), because the original way of doing thing wasn't going to be efficient enough

69 [17:28] but the new API should be all but set in stone
70 [17:28] the changes to the API, by the way, were not very drastic

The API should be pretty much set in stone now, so lenses that worked with 12.04 (after the 11.10 API rewrite) should be still compatible with 13.04.

share|improve this answer
    
That information is a bit out of date. There will be changes to the scope API between 13.04 and 13.10, for instance. I haven't looked at what the changes were between 12.04 and 13.04 though. –  James Henstridge May 3 '13 at 19:33
    
I tried to install lenses but they did not work. –  Dustin May 16 '13 at 16:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.