Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used to be able to keep my power usage under 10 watts without WLAN on but now that rarely happens. One reason might be this, reported by PowerTOP all of the time:

Power est.              Usage       Events/s    Category       Description
8.69 W    100.0%                      Device         USB device: USB2.0-CRW (Generic)

This is especially odd, because this setting is enabled in tunables (via TLP):

   Good          Autosuspend for USB device USB2.0-CRW [Generic]

Is there any way I can a) tell exactly which device/driver this is and b) permanently disable it on startup just to make sure it isn't taking any power?

If it helps, here's my lsusb output:

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 5986:0292 Acer, Inc 
Bus 002 Device 003: ID 0489:e00d Foxconn / Hon Hai Broadcom Bluetooth 2.1 Device
Bus 002 Device 004: ID 0bda:0139 Realtek Semiconductor Corp. Card reader

Here is the USB section from the output of tlp-stat:

+++ USB
tlp usb autosuspend = enabled
tlp usb blacklist   = (not configured)

Bus 001 Device 002 ID 8087:0024 control = auto, autosuspend_delay_ms =  2000 -- Intel     Corp. Integrated Rate Matching Hub (hub)
Bus 002 Device 002 ID 8087:0024 control = auto, autosuspend_delay_ms =  2000 -- Intel Corp. Integrated Rate Matching Hub (hub)
Bus 001 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =  2000 -- Linux Foundation 2.0 root hub (hub)
Bus 002 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =  2000 -- Linux Foundation 2.0 root hub (hub)
Bus 001 Device 003 ID 5986:0292 control = auto, autosuspend_delay_ms =  2000 -- Acer, Inc  (uvcvideo)
Bus 002 Device 003 ID 0489:e00d control = auto, autosuspend_delay_ms =  2000 -- Foxconn / Hon Hai Broadcom Bluetooth 2.1 Device (btusb)
Bus 002 Device 004 ID 0bda:0139 control = auto, autosuspend_delay_ms =  2000 -- Realtek Semiconductor Corp. Card reader (rts5139)
share|improve this question
    
check the config please askubuntu.com/questions/285434/… –  Qasim May 1 '13 at 16:00
    
I looked through /etc/default/tlp and didn't see anything pertaining to the issue. –  Alex May 1 '13 at 16:26
    
on battery ... sudo tlp-stat –  Qasim May 1 '13 at 16:30
    
Alright, I included the USB section (can include other sections if you need) –  Alex May 1 '13 at 16:37
    
do not know .... –  Qasim May 1 '13 at 16:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.