Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have installed Ubuntu 13.04 with daily builds and updated a long the road until now... But one thing that never change is the language settings. I prefer Swedish as default language in menus and settings but even if I uninstall all languages but Swedish I just get english in all menues. What can I do to get Swedish in the menues, I have tried to uninstall all languages and reinstall but still just english..?

share|improve this question

marked as duplicate by user68186, AgentCool, Seth, belacq, Basharat Sialvi May 1 '13 at 18:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

System Settings > Language Support > Languages. You should have a list of your installed languages. By dragging and dropping re-order the list so that Swedish is on the first place. Afterwards, if you wish, you can click Apply system-wide, and also set things up under the Regional Formats tab.

Please note that even if you do all this, you'll have Swedish translated strings only if the translation exists. If any Swedish translations are missing, you'll get English strings instead.

share|improve this answer
    
does anybody know how to do it from cli? –  Dmitry Vyal Nov 16 '13 at 9:26
1  
answering my own question, sudo update-locale LANG=en_US.UTF-8 seems to do the job. –  Dmitry Vyal Nov 16 '13 at 9:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.