Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried to do what mentioned in this link and I entered this code :

echo "foreign-architecture i386" | sudo tee /etc/dpkg/dpkg.cfg.d/multiarch
sudo chmod 644 /etc/dpkg/dpkg.cfg.d/multiarch

Now I see this error.

Unknown configuration key foreign-architecture) found in your (dpkg)
configuration files.  This warning will become a hard error at a later
date, so please remove the offending configuration options and replace
them with (dpkg --add-architecture) invocations at the command line.
share|improve this question
    
Please update your question with what exactly you are trying to do? –  thefourtheye May 1 '13 at 14:12
    
When I was trying to install Nitrotasks, I get this error: The following packages have unmet dependencies. I tried the link I give in first and typed this code echo "foreign-architecture i386" | sudo tee /etc/dpkg/dpkg.cfg.d/multiarch sudo chmod 644 /etc/dpkg/dpkg.cfg.d/multiarch But even that didn't make the problem OK. So I've tried another way to install Nitrotasks by adding repository. That works for me. But I get this error when I entered sudo apt-get update and the error is the dependency error which I typed in last part of question. –  Sina May 1 '13 at 18:18
    
Whats the harm in removing foreign-architecture i386 from your /etc/dpkg/dpkg.cfg.d/multiarch file? –  thefourtheye May 2 '13 at 14:20
    
It's solved by removing it. Thank you @thefourtheye –  Sina May 4 '13 at 11:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.