Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Chrome removes itself from the Internet menu every time I reboot. How can I fix this? The only way to get it back is to reinstall Chrome. Is this a Dev issue or a general error?

I am using Ubuntu 10.04.1 with Gnome. Chrome is the 6.0.495.0 dev version. I downloaded it here: http://www.chromium.org/getting-involved/dev-channel

share|improve this question
    
What desktop are you using? Gnome, KDE, Xfce, ...? Which release of Ubuntu do you use? what is the package release of chrome, where do you get it from? –  txwikinger Aug 22 '10 at 21:18
    
Edited above.... –  Cody Harlow Aug 22 '10 at 21:31
    
Was this installation installed on a removeable storage device, such as a USB disk, or is it in your main home directory ? I'm wondering whether the installed location might not be a permanently available one, that could therefore get it removed from the main menu ? Can you create an icon on your own desktop, and does it remain on the desktop ? If it does remain on the desktop but not on the application menu, there might be an issue around the rights to create documents in some directories. –  jfmessier Aug 23 '10 at 0:37
    
Note: 6.0.495.0 is only currently available in the google-chrome-unstable package. While I don't know if Chrome is causing this particular issue, you may be happier with google-chrome-beta, which is slightly behind -unstable (currently 6.0.472.36). (Chrome adds Google's repositories, using /etc/apt/sources.list.d/google-chrome.list, when you install from .deb, so you can easily use aptitude/synaptic/etc. to switch—just back up ~/.config/google-chrome first.) –  Roger Pate Aug 23 '10 at 5:21
    
I'm using Chrome 5.0.375.127 on Linux Mint 9 (Ubunty 10) with no similar issue. Have you updated the kernel since a fresh install? Sometimes that can cause some strange quirks in the OS. –  Evan Plaice Sep 9 '10 at 4:17

5 Answers 5

up vote 2 down vote accepted

you can create new item on menu list. fill Name with >> Chromium Web Browser, fill Command with >> chromium-browser %U

close the Menu Editor, and now Chromium shortcut will appear on your main Menu. ;)

share|improve this answer
    
This is a workaround, which is good, but it also needs to be fixed in the package –  txwikinger Sep 5 '10 at 1:39
    
This works for now so I'll accept it. –  Cody Harlow Sep 11 '10 at 18:18

This might be a bug in Chrome itself. This person has reported a bug in Launchpad with some information that might be useful. You should grab the information from that bug and file a bug in Google Chrome.

share|improve this answer
    
Isn't that a packaging bug? If so it should probably stay in lauchpad and solved by the maintainers.. –  txwikinger Sep 5 '10 at 1:39
    
It's a 3rd part deb, I would think the bug report would go to Google. However if someone can reproduce it in Chromium also then I would agree. –  Jorge Castro Sep 5 '10 at 4:59

I strongly recommend using Canonical's version of Chrome instead of Google's. I know it's not going to be nearly as bleeding edge, but Google does not put a lot of effort into Ubuntu integration or testing, and this is only one of the types of problems you'll see from it. Others include: Incomplete useragent: "Linux", but not "Ubuntu" Window controls on the wrong side ..and probably a lack of Ubuntu Menu bar support at some point, if Canonical modifies Chromium for Ubuntu Netbook Edition. Seemingly little things, sure, but you've run into one and obviously decided it's worth fixing.

share|improve this answer
    
Your answer has some things you need to correct. In Chrome the window controls are either on the left or right depending on your theme with the current stable release. Also there's no such thing as "Canonical's version of Chrome" and also the menu bar support is still pending (we're working with them on that). –  Jorge Castro Sep 9 '10 at 21:06
    
Interesting.. I'm kind of curious, could you expand on what you said about themes and working with Google on appmenu bar support? –  ethana2 Sep 11 '10 at 4:34

Why not try installing the ubuntu chromium-browser from ppa which is recommended by ethana2. Usually *.desktop file located at /usr/share/applications/ can be edited for displaying in application menu

share|improve this answer

I had the same problem, but i solved it (for me).

If you are using the program "Prey" this might be the problem. Setting the 'Secure' option to OFF (in the 'actions to perform' section of your computer) fixed this problem for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.