Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When using boxee to play video files off of an external western digital 1TB drive formatted NTFS, I notice a slight stutter in the video every 5-10 seconds. When using mplayer, it doesn't stutter as often, but it still stutters occasionally. If I play the video off of the local sata drive, it plays fine even in boxee. I use this computer as my HTPC and I just switched from windows to linux on it. In windows, I never had any sort of stutter playing movies from the drive. I am using the latest intel graphics drivers (for the intel GMA 950)

root@eee-htpc:/home/htpc# grep wd /etc/mtab
/dev/sdb1 /mnt/wd2 fuseblk rw,nosuid,nodev,allow_other,blksize=512 0 0

I notice that despite trying to use ntfs or ntfs-3g, ubuntu uses ntfs-fuse which I've heard is slower.

/dev/sdb1:
Timing buffered disk reads:   80 MB in  3.07 seconds =  26.08 MB/sec

root@eee-htpc:/mnt/wd2# dd if=/dev/zero of=./120mb bs=1024 count=120000
root@eee-htpc:/mnt/wd2# time mv ./120mb /home/htpc

real    0m2.095s
user    0m0.016s
sys     0m0.736s

Even though fuse has a reputation for being slow, it should easily be fast enough for playing standard definition video files.

So why the video stutter?

edit: The issue seems to be overhead cpu usage from either playing off of a usb device or ntfs/fuse. Watching CPU usage with top, local files use 10-40% CPU. Watching the same video on the external formatted ntfs, it spikes to 170% (over 100% because of hyperthreading). To me it seems like it must be overhead from the fuse driver, though I don't know if it has more or less overhead than ntfs-3g.

It's a EEEBox B202 that has an atom 270, so not exactly the most powerful out there.

edit2: I believe the solution would be to use non-fuse drivers or different fuse drivers. so far I have not been able to.

edit3: I've probably edited this more times than I should, but as an update I have upgraded ntfs drivers to ntfs-3g 2010.8.8 external FUSE 28 - Third Generation NTFS Driver using the following PPA - ppa:x3lectric/team-iquik-releases. When first opening a video file in boxee that's on ntfs there's still the same amount of lag. After a few minutes of video, the lag seems to go away and the cpu usage comes down to 10-40%. Every so often though, it begins to stutter again. Also, if I skip ahead/back in the file, it begins to stutter a lot.

share|improve this question

closed as too localized by fossfreedom Feb 20 '12 at 23:23

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Wow thats an elaborate question. Do you automount the drive? ( by lets say an entry in the /etc/fstab?) or do you mount it manually. Try unmounting and mounting the partition using the ntfs-3g driver ( using the -t option of mount) –  tinhed Mar 3 '11 at 21:34
1  
ntfs-3g IS the fuse driver. I think the best thing to do is stop using NTFS. USB also adds a good bit of overhead. Also have you defragged the drive lately? ( In Windows ) –  psusi Mar 3 '11 at 21:44
    
Hello, this question has no information and activity for a very long time. I am closing it for now. If by any reason you think this question is still viable or useful in anyway or that there is still a good chance it will be answered please flag it to a moderator or add a comment with the reason(s) why you want it open. Regards –  fossfreedom Feb 20 '12 at 23:22