Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to recover data from an internal HDD with no OS running Ubuntu 12.04 from an usb drive. With fdisk-l I get this:

   Device  Boot    Start        End      Blocks  ID  System
/dev/sda1             63  976771119  488385528+  42  SFS

I don't know what to do, thanks for helping this poor noob

share|improve this question
    
Any reason you're using SFS File System? –  Mitch May 1 '13 at 3:55
    
no, as long as I remember it was NTFS i don't even know what SFS is –  Axel Mejía May 1 '13 at 5:53
add comment

1 Answer

Try this to fix:

You need to use the ntfsfix command, which is part of NTFS-3g. NTFS-3g should be installed by default. If for some reason its not, then just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below:

sudo apt-get install ntfs-3g

Once done, run this command in terminal:

sudo ntfsfix /dev/sda1

You may have to convert the volume. To do that you might want to take a look at this.

share|improve this answer
    
done, but it still has the same error and with fdisk-l it still says it is SFS System –  Axel Mejía May 1 '13 at 6:31
    
ive solved it, thanks –  Axel Mejía May 1 '13 at 19:37
    
How did you solve it? –  Mitch May 1 '13 at 19:39
    
Weird, this did solve a similar problem I've got :) –  diegoaguilar Nov 6 '13 at 23:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.