Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install the software , which are in software center and new software like virtual box, but it is showing the error:

Items cannot be installed or removed until the package catalog is
repaired, do you want to repair it?

When I clicked the repair icon,it is showing:

Package operation failed, installation or removal of a software
package failed

installArchives() failed: perl: warning: Setting locale failed. perl:
warning: Please check that your locale settings:    LANGUAGE = (unset),
    LC_ALL = (unset),   LANG = "en_IN.ISO8859-1"
    are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). locale: Cannot set LC_CTYPE to
default locale: No such file or directory locale: Cannot set
LC_MESSAGES to default locale: No such file or directory locale:
Cannot set LC_ALL to default locale: No such file or directory perl:
warning: Setting locale failed. perl: warning: Please check that your
locale settings:    LANGUAGE = (unset),     LC_ALL = (unset),   LANG =
"en_IN.ISO8859-1"
    are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). locale: Cannot set LC_CTYPE to
default locale: No such file or directory locale: Cannot set
LC_MESSAGES to default locale: No such file or directory locale:
Cannot set LC_ALL to default locale: No such file or directory perl:
warning: Setting locale failed. perl: warning: Please check that your
locale settings:    LANGUAGE = (unset),     LC_ALL = (unset),   LANG =
"en_IN.ISO8859-1"
    are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). locale: Cannot set LC_CTYPE to
default locale: No such file or directory locale: Cannot set
LC_MESSAGES to default locale: No such file or directory locale:
Cannot set LC_ALL to default locale: No such file or directory perl:
warning: Setting locale failed. perl: warning: Please check that your
locale settings:    LANGUAGE = (unset),     LC_ALL = (unset),   LANG =
"en_IN.ISO8859-1"
    are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). locale: Cannot set LC_CTYPE to
default locale: No such file or directory locale: Cannot set
LC_MESSAGES to default locale: No such file or directory locale:
Cannot set LC_ALL to default locale: No such file or directory
(Reading database ...  (Reading database ... 5% (Reading database ...
10% (Reading database ... 15% (Reading database ... 20% (Reading
database ... 25% (Reading database ... 30% (Reading database ... 35%
(Reading database ... 40% (Reading database ... 45% (Reading database
... 50% (Reading database ... 55% (Reading database ... 60% (Reading
database ... 65% (Reading database ... 70% (Reading database ... 75%
(Reading database ... 80% (Reading database ... 85% (Reading database
... 90% (Reading database ... 95% (Reading database ... 100% (Reading
database ... 195378 files and directories currently installed.)
Unpacking ruby-json-pure (from
.../ruby-json-pure_1.5.1-0ubuntu3_all.deb) ... dpkg: error processing
/var/cache/apt/archives/ruby-json-pure_1.5.1-0ubuntu3_all.deb
(--unpack):  trying to overwrite '/usr/lib/ruby/vendor_ruby/json.rb',
which is also in package ruby-json 1.6.3-1 No apport report written
because MaxReports is reached already Errors were encountered while
processing: 
/var/cache/apt/archives/ruby-json-pure_1.5.1-0ubuntu3_all.deb Error in
function:  dpkg: dependency problems prevent configuration of
ruby-vmc:  ruby-vmc depends on ruby-json-pure (>= 1.5.1); however:  
Package ruby-json-pure is not installed. dpkg: error processing
ruby-vmc (--configure):  dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of
cloudfoundry-client:  cloudfoundry-client depends on ruby-vmc (=
0.3.10-0ubuntu10); however:   Package ruby-vmc is not configured yet. dpkg: error processing cloudfoundry-client (--configure):  dependency
problems - leaving unconfigured

How can fix this problem?

share|improve this question

2 Answers 2

The problem here is that one of Vagrant's dependencies requires the package ruby-json-pure to be installed. However, that is conflicting with the package ruby-json which is already installed. You could try removing the package ruby-json, but that might require you to remove whatever installed it in the first place.

I don't think there is an easy solution to this; it looks like it has been reported as a bug and is fixed in Quantal and above: https://bugs.launchpad.net/ubuntu/+source/ruby-vmc/+bug/1045460

share|improve this answer

I think you want to install the latest Vagrant .deb from their website. It transitioned away from being a Ruby gem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.