Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I installed the detailed Battery Indicator that was shown on OMGUbuntu, and it worked fine for a few days. Now, every time I login I get this: Error

I tried to go back to the old indicator, but it appears to be a D-Bus error. Any ideas?

I'm on Ubuntu 11.04 (Yes, I use Unity. I've also tried NOT using Unity in a hope that it had something to do with that and that the error was misleading, but I got the exact same results) on an Asus EEE PC, and here is what I get when I run cat /proc/acpi/battery/BAT0/info when it's plugged in:

james@tristan:~$ cat /proc/acpi/battery/BAT0/info
present:                 yes
design capacity:         4400 mAh
last full capacity:      4266 mAh
battery technology:      rechargeable
design voltage:          10800 mV
design capacity warning: 10 mAh
design capacity low:     5 mAh
cycle count:          0
capacity granularity 1:  44 mAh
capacity granularity 2:  44 mAh
model number:            1005P
serial number:            
battery type:            LION
OEM info:                ASUS
james@tristan:~$

I get the exact same output when I'm not plugged in as well.

*EDIT: THERE IS NO BAT1. I'm now on 11.04 beta, and I'm still getting the same error

Another edit: Output of acpitool -b

Battery #1 : discharging, 100.0%

share|improve this question
    
By "plugged in" do you mean that the battery is plugged in or that the AC adapter is plugged in? Also, what exactly happened when you tried to go back to the old indicator? –  ændrük Mar 3 '11 at 19:34
    
Battery is always plugged in - although I did take it out for a moment to see if that was the problem. What I meant by "plugged in" was that the AC adapter is plugged in. As for what happened when I tried to go back, nothing. I selected the indicator applet in normal GNOME, and it didn't do anything - no new icon in the menubar, no error. Nothing happened. Most annoying/puzzling. –  jrg Mar 3 '11 at 20:17
    
Could you please install acpitool and provide the output of acpitool -B without the adapter plugged in? Note: it might be -b and not -B. My laptop's in Windows & I can't reboot for a few minutes, but I'm asking for the acpi battery output info (definitely available via acpitool -e, but that's a bit verbose for here...) –  M. Tibbits Apr 4 '11 at 18:28
    
@M tibbits Done –  jrg Apr 4 '11 at 18:39

1 Answer 1

up vote 3 down vote accepted
+50

There is a know bug that can be solved by this: Lets make a backup first:

 sudo cp /usr/lib/battery-status/battery-status /usr/lib/battery-status/battery-status.bak 

And then:

 sudo sed -i 's/BAT0/BAT1/g' /usr/lib/battery-status/battery-status 
share|improve this answer
    
gist.github.com/1c510b08c587a8cacb19 - the PPA isn't found. –  jrg Apr 4 '11 at 17:57
    
I'm sorry I am at my mobile. I will check that when I get home. Until then you could try what I've added to the answer. –  desgua Apr 4 '11 at 18:43
    
You just solved it for me. I followed your instructions, logged out and it worked.... THANK YOU. :D –  jrg Apr 4 '11 at 18:44
    
I'm glad to help. ;-) –  desgua Apr 4 '11 at 18:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.