Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just updated from 12.10. Ubuntu cannot shutdown properly, it hangs at the purple ubuntu loading screen with dots animation still moving. It hanged about half an hour. I hold the power button to shut it down.

I happened on every boot. Please help. This is all that I know.

1/5/2013 - 6:59 I tried sudo service lightdm restart code, and returns in console (black screen):

Asking for cache data failed
Assuming drive cache: write through

then after a half screen of attempts, the screen black out (screen saving).

I pressed the power button and another shutdown procedure began.

IMAGES:

http://imageshack.us/photo/my-images/163/sany0427q.jpg/

http://imageshack.us/photo/my-images/10/sany0428r.jpg/

share|improve this question
    
I also have this problem. It is solved when I take out the battery from my laptop and then shut down with the power button. Then try to boot and restart, after that the battery can be reinserted. –  user154288 May 1 '13 at 2:10
    
Possible duplicate of this or this. –  AliNa May 1 '13 at 4:04
    
not a duplication since there is no freeze or blank screen –  Daniel Cheung May 1 '13 at 10:48

1 Answer 1

I also face the same problem frequently! I installed a new version of ubuntu13.04 64bit.

Also, when starting the ubuntu13.04, I have to run two times of this command!

sudo service lightdm restart

It seems that some driver or software problem makes it happen.

share|improve this answer
    
I did it, says in console Asking for cache data fail, Assuming drive cache: WRITE THROUGH –  Daniel Cheung May 1 '13 at 10:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.