Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a very strange problem in Ubuntu 13.04: GUI problem

I can only boot into the cairo-dock session and as you can see, some of the screen is missing. Another issue is that the window borders (with the close, minimize, maximize) is missing. It only did this once before during the upgrade, but worked on the next boot. I didn't install any packages my last session, only an hour or two of VMs. So now I am stuck with Winows 8 :(. Any help would be greatly appreciated!

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

This happens because the window compositor and decorator (compiz) is not running. It's probably crashing.

The black areas are "transparent" areas requiring a window compositor running.

Just to get you working again, install the package gnome-panel from the terminal. After booting, without logging in, press Control+Alt+F1, login in the console and use this command:

sudo apt-get install gnome-panel

Once you've installed gnome-panel, reboot or go back to the login screen with Alt+F7 and choose the session Gnome Classic (no effects).

To get compiz working again, so you can run Unity and Cairo-dock properly, we have to determine what's going wrong. That would be probably one of these:

  • Compiz is not installed properly. Run sudo apt-get install --reinstall compiz from a terminal to make sure that compiz is installed.
  • Your user profile has some bad configuration for Compiz. Create a new user and try to login with that user on Cairo Dock or Unity. If that succeeds, you'll have to reset the Compiz configuration on your user to fix it.
  • Your graphic drivers are not installed properly or are having some trouble running compiz. Run compiz --replace | tee output_compiz.txt from the Gnome Classic session to see what's going on. Paste here the generated file output_compiz.txt Please add what graphics card, driver are you using.

Please notice that, at any moment, you can login into a console by pressing Ctrl+Alt+F1 and run this command to kill your session:

killall gnome-session

This comes in handy if you're having trouble with the window compositor/decorator and want to go back to the login screen. Press Alt+F7 or Alt+F8 to go back to the graphical session after doing this.

share|improve this answer
    
Thanks! The first option worked almost perfectly. For some reason, I am now missing terminal (except for Cairo one) and virtualbox, but it shows they are both installed. I will make this a new thread if I need to. –  Bf109guy May 1 '13 at 5:26
    
(Sorry, forgot to add this). I also get a blinking underscore on every other boot after grub –  Bf109guy May 1 '13 at 5:34
1  
The terminal package is gnome-terminal, and virtualbox depends, but the package contains the word virtualbox for sure. Do dpkg -l | grep virtualbox | grep ii and if you get no results, it's NOT installed. The same for gnome-terminal. The blinking underscore seems like a problem with your graphics card. Please post another question about that detailing your graphics card, what driver are you using, etc. –  Jorge Suárez de Lis May 1 '13 at 8:16
    
The blinking underscore was trying to find the HDD. It worked after a minute or two. I also just noticed all unity apps (including the terminal) are missing. The session is also missing. Thanks for the help –  Bf109guy May 1 '13 at 20:46
    
So just install the package ubuntu-desktop. Everything should be fixed then. –  Jorge Suárez de Lis May 2 '13 at 12:05
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.