Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I built a computer for my music this weekend, I have a little problem though; my Seagate 1TB hard drive isn't showing up in the Asus BIOS screen when I connected it. It's showing up in Ubuntu disks application and it isn't partitioned or formatted yet, is that preventing it from showing up in BIOS screen, or is it caused by something else?

When I disconnect my SSD, my 1TB hard drive shows up in the BIOS screen, but not when my both hard drives are connected. So does that mean it's detected? How do I partition and format a hard drive to both Ubuntu and Windows format, so I can install my Windows software I use daily and my computer internal components on Ubuntu?

Components:
Asus P8h61-MLE/CSM R2.0 H61 LGA 1155 Micro ATA motherboard
Intel Pentium G860 Sandy Bridge 3.0Ghz LGA1155 65W Processor
Ark Technology PN03 mAtx Mini-Tower PC Case(black) with 500W PSU
Asus DWR-24B1ST Internal SATA DVD-RW DRIVE(black)
Intel FAN- 1155 LGA 1155 Cooling Fan base
Seagate ST1000VM002 1TB 3GB/s PipelineHD SATA 2 Hard Drive
EVGA 01G-P3-1312-LR GeForce 210 PCle 2.0 x 16 1GB Video Card
FileMate 3FMPCIMWN-R 802 11n/g Wireless N PCl Wifi Network Adapter
Corsair CSSD-F120GB2-RF2 Force 2.5 120GB SATA 2 SSD
G Skill f3-17000CL 11D-8GBSR Sniper 8GB (2X4GB) DDR3-2133Mhz RAM

share|improve this question
2  
Please try to separate your two questions: Your issue with the hard drive not appearing in the BIOS, and the question of how to format a drive for both Ubuntu and Windows (although the second one is probably a duplicate). –  Kupiakos Apr 30 '13 at 20:28
    
Welcome to Ask Ubuntu! It is preferred if you can post separate questions instead of combining your questions into one. That way, it helps the people answering your question and also others hunting for at least one of your questions. Thanks! –  guntbert Apr 30 '13 at 20:34

1 Answer 1

If you have a third hard drive to test, answer these questions:

  • If you plug in the third drive and the SSD, do both appear in the BIOS?
  • If you plug in the third drive and the 1 TB drive, do both appear in the BIOS?

Remember to reset the computer between each test - the BIOS doesn't usually detect changes and display in the settings live.

If the first situation works and the second doesn't, the problem lies in your 1 TB drive.

If the second situation works and the first doesn't, the problem lies in your SSD.

If both situations don't work, the problem is most likely in your BIOS or hardware somewhere.

If both situations work, something funky is happening. Try plugging in the SSD and 1 TB drive in at the same time again (after resetting the computer) and seeing if it works.

share|improve this answer
    
I did what you told me to do, with my external hard drive and I did it with my flash drive too. all three hard drives didn't show up separate in my BIOS, I think it only shows them in a one hard drive fashion? Is the problem in my BIOS or a hardware dysfunctional? –  D Swagger Apr 30 '13 at 22:46
    
The hard drives show up individually though. –  D Swagger Apr 30 '13 at 22:53
    
Can you please explain more explicitly what your BIOS reports in each of these situations? –  Kupiakos May 1 '13 at 23:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.