Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Trying to install Ubuntu on a Windows machine running Windows 7. I started by using the WUBI, but when I restarted the computer it just went straight to Windows. Then I went into the disk management on Windows, shrank the volume by 30gb, setup the 30gb non-allocated space as E drive with FAT32 and restarted the computer with a USB Live setup of Ubuntu. I went into Run Ubuntu from USB, started the Installer and it doesn't detect my Windows install. When I hit the option to "do something else" it sees the NTFS partition AND the FAT32 partition (which I then reformatted as Ext3). The Windows partition IS /dev/sda1 but for whatever reason the installer doesn't know that it is Windows 7.

I ran sudo fdisk -lu


Disk /dev/sda: 320.1 GB, 320072933376 bytes
240 heads, 63 sectors/track, 41345 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x6c3782f5

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   563697663   281847808    7  HPFS/NTFS/exFAT
/dev/sda2       563697664   625137663    30720000    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 8103 MB, 8103395328 bytes
255 heads, 63 sectors/track, 985 cylinders, total 15826944 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048    15826943     7912448    b  W95 FAT 32

The Windows 7 partition is NOT showing up when I run BLKID

/dev/loop0: TYPE="squashfs"
/dev/sdb1: LABEL="PENDRIVE" UUID="FC0F-1FF1" TYPE="vfat"

If I go through the install and select to put it on the /dev/sda2, then whenever I reboot the computer it goes DIRECTLY to Ubuntu, no option for Windows.... no grub, nothing.

It should be noted that this is a work owned computer that has a full disk encryption on it. I am guessing that MIGHT be the problem, but I really don't know.

I am trying to do this on a computer that belongs to another guy on the project. My computer has a full disk encryption (different brand) and I have Ubuntu 12.04 LTS on it with no problems.

Any advice on how to move forward would be really helpful!

share|improve this question
    
Run sudo blkid. Does that change the output? –  thirtythreeforty Apr 30 '13 at 17:37
    
Also, what type of full disk encryption are you using? Linux has support for its native LUKS platform and Truecrypt (if you install it). Other solutions, especially BitLocker, are unlikely to work, because they're proprietary. (Whether you trust proprietary crypto software is another issue entirely...) If Linux doesn't support the crypto setup, it will just appear as an unformatted block device. Unless you fancy losing the entire partition, don't touch it! By the way, the best way I've found to get crypto on both Linux and Windows is Truecrypt's Windows disk encryption and Linux's LUKS. –  thirtythreeforty Apr 30 '13 at 17:41

1 Answer 1

There are 2 possible reasons for this behaviour:

  1. perhaps the timeout-value from the grub-menu is set to 0, then grub will start the default OS.

  2. the grub-config has no information about the windows partition in both cases the wrong config should be found in the config-files under/etc/grub.d

Hope this will help, kind regards

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.