Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am not talking about the Win 98 look, but even with the gnome-integration installed buttons look a bit weird and there are sometimes black lines where there shouldn't be any. Why?

enter image description here

share|improve this question
    
Are you talking about the line behind 'basic fonts (Western) at the top? –  user unknown Mar 3 '11 at 13:09
1  
He means around the buttons, there is a lighter grey square surrounding the button. –  Weboide Mar 3 '11 at 14:25

4 Answers 4

up vote 1 down vote accepted

This will be improved in LibO 3.4 --see this before-n-after screenshot: https://bugs.freedesktop.org/attachment.cgi?id=42337

share|improve this answer

It's not using the standard GTK-toolkit - I think it has its own kit... The differences are subtle and many people doesn't seem to notice. But I think it's butt-ugly :/

Even with openoffice.org-gtkInstall oppenoffice.org-gtk and openoffice.org-gnomeInstall openoffice.org-gnome installed.

You can try with a different theme in ubuntu to remove thick black lines though. It's an Ambience glitch.

share|improve this answer
    
Do you know how hard it would be to fix these bugs or move to the standard-GTK? –  Toxicbits Mar 3 '11 at 16:09
    
This answer is a bit wrong, as it does use gtk, just indirectly. The toolkit is called VCL, and it tries to mimic gtk, so it respects gtk themes, but it's imperfect (very). –  RolandiXor Mar 3 '11 at 16:27
    
@Roland, I'm also interested in @Toxicbits' problem - how difficult would it be for LO to directly use GTK+? –  Oxwivi Mar 3 '11 at 16:37
    
I'm not a LO developer, but to my knowledge at this point it would take a lot of work, because libreoffice still has a long way to go to free itself of its OOo past –  RolandiXor Mar 3 '11 at 16:46

install openoffice.org-gtk and openoffice.org-gnome packages

sudo apt-get install openoffice.org-gtk openoffice.org-gnome

share|improve this answer
    
I have them installed, that's not the issue. –  Toxicbits Mar 3 '11 at 16:09

To make LibreOffice look and feel in a Gnome setting copy and paste this command into the Terminal.

sudo apt-get install libreoffice-gnome

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.