Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a folder on my disk which I share over the LAN so my wife can do backups to it. It has worked since I can remember. Now I've updated to 13.04 and suddenly I no longer see it or even my computer over the LAN.

I am referring to File (or Nautilus) where I press the Browse Network button. I used to see my own machine and hers, and of course the shared folder.

I tried to remove sharing from the file and then reshare it. I did a log out, log in but still no sign of my computer or the shared folder. I see her computer but not my own and of course she fails to see my computer as well.

I assume samba is working or I would have received a message when I did the reshare. The problem began after the upgrade to 13.04. Any suggestions? Thanks, Ilan

share|improve this question
add comment

1 Answer

I suspected that maybe samba was broken so I went into synaptic and completely removed it.

Just to be sure I did log out/log in after each critical step.

Then I reinstalled samba and if I remember correctly at this stage at least my computer reappeared when I hit Browse Network inside Nautilus (it may have appeared at a later stage).

The Sharing Options upon a right click was no longer available and the critical point here is to use synaptic to install nautilus-share. It probably was removed when I removed samba.

Finally I had a password problem in that I couldn't open the folder which I wanted to share to my wife. The point here is to use a terminal and type shares-admin. Unlock it and in the Users tab I saw my login user name, so I checked it and set my login password.

After that I was back on line. How it got broken in the first place is still a mystery, but at least my shared folder in now back on line.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.