Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've made a clean install of 13.04 64-bit on a Dell Vostro 3500 i5 4gb RAM. The apps are working properly when installed after the Firefox requests, only Gmail (which was a troubled app for some systems on previous versions also) doesn't appear on Unity and on the Messaging Menu. I've tried to reinstall the app via Synaptic, but no results. Would there already be a way to solve this in 13.04? Thanks in advance.

share|improve this question

2 Answers 2

In case you want to retry adding the Gmail Unity webapp from firefox: execute sudo apt-get purge unity-webapps-gmail, restart firefox and surf to https://gmail.com. You should see the dialog asking to install the gmail webapp.

I'm experiencing the same issue, one thing I've noticed is that the file ~/.local/share/applications/GMailmailgooglecom.desktop was missing on my system. I created it and populated it with (you can create it by running unity-webapps-desktop-file /usr/share/unity-webapps/userscripts/unity-webapps-gmail/manifest.json in ~/.local/share/applications):

[Desktop Entry]
Name=GMail
Type=Application
Icon=GMail-mail.google.com
MimeType=
Actions=S0;S1;S2;S3;S4;S5;S6;S7;S8;S9;S10;
Exec=unity-webapps-runner -n 'R01haWwA' -d 'mail.google.com' %u

I also added a row for the GMail app to the applications table in ~/.local/share/unity-webapps/apps2.db and checked that the necessary values are present in dconf-editor (as suggested by sorgel).

After restarting unity I do have a GMail icon on my Unity launcher and the messages menu, the icon itself however is displayed as a question mark. Clicking the question mark in the launcher always opens a new firefox window (i.e. it doesn't switch to an existing tab if present); also the number of unread mails isn't displayed either.

So for me the webapp basically doesn't work. The Facebook, twitter and Youtube webapps do seem to be operating as expected. Filing a bug report would probably be the next step.

share|improve this answer

Visit http://gmail.com and your browser will ask you to install it, accept and it will pop the dialog to login and allow the app to access gmail info. Fill that in and let it do its magic work. You can add it manually via system settings >>Online Accounts

Once you visit gmail it will showup!

I tried it on my 13.04 with Firefox 20 and it works fine.

share|improve this answer
    
I did it already and it it doesn't work with my Firefox browser. When I first accessed Gmail, there was a request to install the app. When I did allow it, nothing happened. It doesn't appear anywhere, not even in Dash. Did you have to update the browser for the Gmail App to work? –  user153634 Apr 30 '13 at 12:57
    
Please, try this: run dconf -> com -> canonical -> unity -> webapps. "Allowed domains" should contain 'mail.google.com'. Also look at dconf -> com -> canonical -> indicator -> messages: "applications" should contain 'GMailmailgooglecom.desktop'. –  sorgel Apr 30 '13 at 13:17
    
I believe gmail is not blocked (as long as you installed it first time it asked). Unless (s)he tampered with configs somewhere! –  Stefano Mtangoo Apr 30 '13 at 20:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.