Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was following this guide (https://help.ubuntu.com/community/OpenCV) in order to install openCV.

sudo su
sudo apt-get install build-essential
sudo apt-get install libavformat-dev
sudo apt-get install ffmpeg
sudo apt-get install libcv2.3 libcvaux2.3 libhighgui2.3 python-opencv opencv-doc libcv-dev libcvaux-dev libhighgui-dev

I also runned the incomplete command :

sudo apt-get install libcv2.3 libcvaux2.3 libhighgui2.3 python-

the first time, by mistake, but i guess that shouldn't do anything wrong..

I also runned a

sudo apt-get autoremove

at some point.

After this, the ubuntu interface got all strange, resembling what this post describes..: Launcher and window menu bar missing after 12.04 upgrade

However, that's not the only issue... Some programs I had installed don't get their commands auto completed in the terminal anymore and I cannot find their bins at all...

I don't understand... it looks like something removed a lot of random programs.... like firefox, terminator... and maybe unity? Could it be that apt-get triggered some kind of update process that was interrupted? I don't have idea of what is going on here..

I already tried

sudo apt-get -f install 

but it didn't solve anything.

Installing unity restored some interface elements but almost all my launcher icons are gonne and the interface skin is horrible and glitchy....

Any suggestions? I would like to be able to recover my programs back :(

Thanks.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Get to a TTY (Control+Alt+F1), check if ubuntu-desktop is installed:

$ apt-cache policy ubuntu-desktop
ubuntu-desktop:
  Installed: (none)
  Candidate: 1.299
  Version table:
     1.299 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages

In my case it is not. I assume you've triggered a cascade removal of certain packages and that has nuked Unity. To fix, just reinstall ubuntu-desktop and all should be fixed.

sudo apt-get install ubuntu-desktop
share|improve this answer
    
This solved some of the problems!unity is back and firefox too.. but my other programs... where are they? dropbox, terminator, and who knows which others I didn't notice yet.. Are they gone for good? :( –  joxnas Apr 30 '13 at 18:38
    
For good? You'll have to reinstall them because you removed one or more of their dependencies... There's no quick way to get around that. –  Oli Apr 30 '13 at 20:41
    
What did I do wrong? As far as I understand, "autoremove is used to remove packages that were automatically installed to satisfy dependencies for some package and that are no more needed." My programs were neither installed automatically or merely to satisfy dependencies. –  joxnas Apr 30 '13 at 21:10
    
Actually installing python- (which is what your install line equates to) will remove a whole ton of stuff. You can test it without any damage by running: apt-get -s install python- (sudo not needed) and you'll see what I'm talking about. I'll start a question about that now. –  Oli May 1 '13 at 8:02
    
See: askubuntu.com/questions/214043/… A - suffix means "remove" even in an install line so that was knocking out python and that is depended on by a huge raft of packages. –  Oli May 1 '13 at 8:19
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.