Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Ubuntu 13.04 desktop I am trying to change keyboard layout.

First in System Settings -> Keyboard Layout -> Options -> Alt-Win behaviour, I picked the following mapping:

Ctrl is mapped to Alt

Alt is mapped to Win.

And that works perfect.

Now I want to change shortcut for application switching (since I swapped keys it is Win-Tab now, I want it back on Alt-Tab)

In System Settings -> Keyboard -> Shortcuts -> Navigation, I picked new combination for Switch Applications.

It is properly detected as Ctrl-Tab, but it is not working. It still works as Alt-Tab (since I swapped keyboard in first step, it is actually Win-Tab).

Is this a bug ? Is there any way I can change combination for switching applications ? Thanks.

share|improve this question

1 Answer 1

On Ubuntu 14.10 I've solved this issue by installing compizconfig

sudo apt-get install compizconfig-settings-manager

In compiz go to Ubuntu Unity Plugin > Switcher and set "Key to start the Switcher" to Ctrl+Tab

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.