Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dual boot (w7, ubuntu 12.10 ) laptop. Everything was OK since some weeks. Now I am unable to boot my ubuntu 99 times of a hundred.

The process start with the bios settings and all, then grub screen shows up normally ( with all the correct options ) then, when I choose ubuntu option screen turns black ( with back-light ) and that's all ...

I have tried with Ctrl+Alt+F1 to try to drop to the root console but nothing happens ...

IF I try enough times the logging screen shows up and from there everything goes smoothly.

This is my first serious issue with Ubuntu (and I'm using it since 8.04 version ) and I have no idea where to start investigating ...

This error has made my computer unusable so please, I need help ...

Thanks for all in advance.

P.S.:Since I updated to 12.10 while I am working normally from time to time a window pops up with a "System program problem detected". I haven't found a way to get more details about the problem and after reading some web sites seems something "normal" ( or at least common ) but I mention it here just in case.

share|improve this question
add comment

2 Answers

I am not sure if this is the same problem I had, but this solved it for me:

in grub select the ubuntu entry and press e. now look for the words 'quiet splash'. delete them and type 'nomodeset' in stead. now press f10 to boot into ubuntu. I can not tell you what happens or why it works, but for me it did. I got my answer from here.

share|improve this answer
    
Thanks for your answer @user146890 . I have tried the nomodeset option, the behaviour has changed, now the power button works ( a short push shutdown the laptop while before I have to long press to switch it off ) but the problem is still there: BlackSreen and no root console wuth Ctrl+Atl+F1 ... still (almost) the same problem. –  thamurath May 1 '13 at 9:28
    
@thamurath a pitty the nomodeset option did not work, you could try to reinstall grub, I used this program recently, and it helped me trough the process. otherwise I would start thinking of a fresh install, but maybe someone else will come up with a better solution... –  Wouter May 1 '13 at 9:56
add comment
up vote 0 down vote accepted

well it seems that the problem is the kernel version.

Last kernel update was 3.5.0-27 and it seems it has some problems with the video drivers of multiple graphic cards. After reading this two bug reports I thought the kernel could be the problem and try to boot with the 3.5.0-26 ( thanks good that ubuntu stores the last used kernels just in case ), no problem since then. I have been able to boot my laptop 10 times from 10 tries so I think the problem was the kernel.

I do not know what the problem was exactly and the bug reports are not solved yet, so until then I will not update my system to the 3.5.0-27 kernel version.

Thanks for your answers

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.