Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Graphics Performance is Worse in Ubuntu 12.04 LTS than Windows XP: Using- Intel® 945G x86/MMX/SSE2

In Windows XP Professional, the graphics process much more effectively. I can watch HD videos without losing frames and can play the exact same games, again, without nearly as much of what seems like very poor frames per second. Gets pretty choppy, irregardless of ping, in game. Overall, XP Professional is way smoother in seemingly every way, and not sure why.

Also, it says "Standard" regarding my Experience in System Settings, under Details in Ubuntu 12.04 LTS.

share|improve this question

closed as not a real question by Mitch, Basharat Sialvi, jrg Apr 30 '13 at 11:22

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

First of all, your complaining "You need to fix it" attitude is why no one responded to your question. Realize that you aren't paying anyone for Ubuntu, everyone's doing you a favor and working hard to make something that works for all of us.

On to your question, try ensuring that all of your drivers are set proprietary under:

System Settings > Software Sources > Additional Drivers

share|improve this answer
    
Not a real question? I don't get it. If you are sick of helping people for free, then don't, but that's not really my problem. I have made the inquiry, and that's it. I have tried tons of things, and I just posted my question. Ok, I have no proprietary drivers, guessing I'll need to find them, then install. Will let you guys know. Ubuntu is supposed to be better than Windows XP, based on reviews, which is why I am not complaining, but contrasting. –  user153907 May 1 '13 at 23:39
    
Guessing the answer might also be that I need to do a fresh install, since things like automated standby do not function. –  user153907 May 1 '13 at 23:55
    
Well, it isn't really something specific as opposed to a general problem. You'd fare better in the forums. But, either way, try what I said above and restart, if it improves, mark the solution. –  haneefmubarak May 2 '13 at 7:10
    
Well nothing so far works, I was able to install some intel driver installer, but didn't help. I think I may have issues with streaming HD on windows as well, but it has no problems with the game. Maybe it's just the game, dunno, haven't played anything like it on Ubuntu before, maybe its Ubuntu release just plain sucks, and windows one doesn't. Second Life though, also performs much worse on Ubuntu than my Windows XP, due to poor graphics processing even on earlier versions of Ubuntu, it's not bandwidth. I don't think everyone has those problems. –  user153907 May 8 '13 at 23:45
    
I have heard that installing an earlier version might also work, but haven't tried it. I haven't tried reinstalling the entire OS, but I guess I'll probably have to. –  user153907 May 8 '13 at 23:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.