Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My internet was working fine till tomorrow. Suddenly I am not able to open www.github.com, www.deviantart.com and additionally my router configuration page 192.168.2.1 . First, I thought that it would be a problem with my ISP (i have a DSL connection). I have a dual-boot system with win7, so checked the connection there. It all worked fine! Certainly it was not the ISP who was troubling, it had to do something with Ubuntu.

Problems and errors:

Github says:

This webpage is not available
Google Chrome could not load the webpage because github.com took too long to respond. The website may be down, or you may be experiencing issues with your Internet connection.
Here are some suggestions:
Reload this webpage later.
Check your Internet connection. Restart any router, modem, or other network devices you may be using.
Add Google Chrome as a permitted program in your firewall's or antivirus software's settings. If it is already a permitted program, try deleting it from the list of permitted programs and adding it again.
If you use a proxy server, check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server, adjust your proxy settings: Go to the Chrome menu > Settings > Show advanced settings... > Change proxy settings... and make sure your configuration is set to "no proxy" or "direct."
Error 7 (net::ERR_TIMED_OUT): The operation timed out.

The same goes with the router configuration page, while deviantart takes forever to load.

What I tried:

I read some previous posts on this topic, and I tried the following:
1) I use google chrome. I switched to firefox on ubuntu but didn't work.
2) cleared the cache and cookies, but no.
3) Set the primary DNS server to google public dns, then to open dns, still nothing.
4) Tried to set the primary DNS to 192.168.2.1 , still no.
5) I reset my router, configured it from scratch in win7 and came back to ubuntu, to see that the problem still persisted.
6) pinged www.github.com and then google.com, here are the results:

PING www.github.com (204.232.175.90) 56(84) bytes of data.
64 bytes from github.com (204.232.175.90): icmp_req=1 ttl=53 time=390 ms
64 bytes from github.com (204.232.175.90): icmp_req=2 ttl=53 time=392 ms
64 bytes from github.com (204.232.175.90): icmp_req=3 ttl=53 time=384 ms
64 bytes from github.com (204.232.175.90): icmp_req=4 ttl=53 time=394 ms
64 bytes from github.com (204.232.175.90): icmp_req=5 ttl=53 time=396 ms
64 bytes from github.com (204.232.175.90): icmp_req=6 ttl=53 time=402 ms
64 bytes from github.com (204.232.175.90): icmp_req=7 ttl=53 time=397 ms
64 bytes from github.com (204.232.175.90): icmp_req=9 ttl=53 time=402 ms
64 bytes from github.com (204.232.175.90): icmp_req=10 ttl=53 time=397 ms
64 bytes from github.com (204.232.175.90): icmp_req=11 ttl=53 time=397 ms
64 bytes from github.com (204.232.175.90): icmp_req=12 ttl=53 time=398 ms
64 bytes from github.com (204.232.175.90): icmp_req=13 ttl=53 time=400 ms
64 bytes from github.com (204.232.175.90): icmp_req=14 ttl=53 time=399 ms
64 bytes from github.com (204.232.175.90): icmp_req=15 ttl=53 time=403 ms
64 bytes from github.com (204.232.175.90): icmp_req=16 ttl=53 time=404 ms
64 bytes from github.com (204.232.175.90): icmp_req=17 ttl=53 time=406 ms
64 bytes from github.com (204.232.175.90): icmp_req=18 ttl=53 time=403 ms
--- www.github.com ping statistics ---
18 packets transmitted, 17 received, 5% packet loss, time 31092ms
rtt min/avg/max/mdev = 384.510/398.374/406.145/5.407 ms


PING www.google.com (173.194.38.176) 56(84) bytes of data.
64 bytes from sin04s02-in-f16.1e100.net (173.194.38.176): icmp_req=1 ttl=53 time=132 ms
64 bytes from sin04s02-in-f16.1e100.net (173.194.38.176): icmp_req=2 ttl=53 time=130 ms
64 bytes from sin04s02-in-f16.1e100.net (173.194.38.176): icmp_req=3 ttl=53 time=128 ms
64 bytes from sin04s02-in-f16.1e100.net (173.194.38.176): icmp_req=4 ttl=53 time=126 ms
64 bytes from sin04s02-in-f16.1e100.net (173.194.38.176): icmp_req=5 ttl=53 time=129 ms
64 bytes from sin04s02-in-f16.1e100.net (173.194.38.176): icmp_req=6 ttl=53 time=128 ms
64 bytes from sin04s02-in-f16.1e100.net (173.194.38.176): icmp_req=7 ttl=53 time=133 ms
64 bytes from sin04s02-in-f16.1e100.net (173.194.38.176): icmp_req=8 ttl=53 time=123 ms
64 bytes from sin04s02-in-f16.1e100.net (173.194.38.176): icmp_req=9 ttl=53 time=131 ms
64 bytes from sin04s02-in-f16.1e100.net (173.194.38.176): icmp_req=10 ttl=53 time=119 ms
64 bytes from sin04s02-in-f16.1e100.net (173.194.38.176): icmp_req=11 ttl=53 time=127 ms
^C
--- www.google.com ping statistics ---
11 packets transmitted, 11 received, 0% packet loss, time 10009ms
rtt min/avg/max/mdev = 119.351/128.304/133.168/3.983 ms

I am positive that I have no proxy and IPv6 is disabled.

Please help me with the problem.

share|improve this question
    
Looks extremely similar to my situation. Try the solutions given here: Problem resolving many of the Web Pages –  Aditya Apr 29 '13 at 18:49
    
Thanks @Aditya , already tried some of them. –  syfluqs Apr 29 '13 at 18:51
    
Did you try laurent's answer - the one which is accepted? –  Aditya Apr 29 '13 at 18:53
    
Is this wired or wireless? Which driver? –  chili555 Apr 29 '13 at 20:08

2 Answers 2

This sounds like a temporary routing issue with your ISP. You can update me if your computer is still having problems, but often these issues are certainly to do with the connection between the router and the target website.

To eliminate the browser, use wget on the command line to download the github or deviantart website. If that fails... then you need to run some diagnostics to find where the error is happening with http requests.

share|improve this answer

You should re-install your browser first. Then if the problem persists it maybe an issue with your firewall configuration.

  1. In case firewall occurs the problem then disable your firewall or if you can configure then configure it with choice. It will solve your problem.

  2. If you have any proxy software installed then uninstall it immediately.

  3. If you have a router which is broadcasting your internet then check your router's firewall settings. There maybe some options to: Filter ActiveX, Filter Java Aplets, Filter Proxy etc. Disable these things. Or command the firewall not to filter these things. Then you will be able to access the web pages you want.

  4. You can also check your router if these websites are blocked or not from your router. If blocked then unblock these websites to access them.

  5. It might be a temporary issue with your ISP. In many rear cases ISP does some website blocking. Hope the problem isn't related with your ISP. If so then contact your ISP to unblock these websites.

Hope this will help. If need further help then provide the problem with more details like snapshots etc.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.